summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-06 00:00:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-06 00:00:47 +0000
commit971ec0283cd118fff3b7947f5b687446829b6e61 (patch)
tree1d7dacbe67c23169b2866caf251d19a103203c09
parentf7e56763e12bdff2261929bbcb691e770341d043 (diff)
downloadmaster-31e0f0ae-971ec0283cd118fff3b7947f5b687446829b6e61.tar.gz
master-31e0f0ae-971ec0283cd118fff3b7947f5b687446829b6e61.tar.bz2
master-31e0f0ae-971ec0283cd118fff3b7947f5b687446829b6e61.zip
include: remove static tool linking support
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44286
-rw-r--r--include/host-build.mk6
-rw-r--r--include/prereq-build.mk18
2 files changed, 0 insertions, 24 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index ad821f72c4..b93f70ffd5 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -73,12 +73,6 @@ HOST_MAKE_FLAGS =
HOST_CONFIGURE_CMD = $(BASH) ./configure
-ifneq ($(HOST_OS),Darwin)
- ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
- HOST_STATIC_LINKING = -static
- endif
-endif
-
define Host/Configure/Default
$(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
if [ -x configure ]; then \
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 306a6b3e38..1c8de0638e 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -68,24 +68,6 @@ $(eval $(call TestHostCommand,libssl, \
echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
-ifneq ($(HOST_STATIC_LINKING),)
- $(eval $(call TestHostCommand,working-gcc-static, \
- Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL)., \
- echo 'int main(int argc, char **argv) { return 0; }' | \
- gcc -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out -))
-
- $(eval $(call TestHostCommand,working-g++-static, \
- Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL)., \
- echo 'int main(int argc, char **argv) { return 0; }' | \
- g++ -x c++ $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lstdc++ && \
- $(TMP_DIR)/a.out))
-
- $(eval $(call TestHostCommand,zlib-static, \
- Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL)., \
- echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
- gcc -include zlib.h -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lz))
-endif
-
$(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
gtar --version 2>&1 | grep GNU, \