summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-01-19 23:25:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-01-19 23:25:38 +0000
commit939b944c6e2573787dedf69ce7b390fe4381388e (patch)
tree0c73ae5baeb723a25ba22d834465d1577563b7f9
parentf6e4badfe4146c732fd3a1529cf6b1b270ea6ea3 (diff)
downloadmaster-31e0f0ae-939b944c6e2573787dedf69ce7b390fe4381388e.tar.gz
master-31e0f0ae-939b944c6e2573787dedf69ce7b390fe4381388e.tar.bz2
master-31e0f0ae-939b944c6e2573787dedf69ce7b390fe4381388e.zip
Revert "6in4: Corrected tunnelbroker tunnel update URL"
The auth change appears to break the endpoint update for most users and with my local tests the old update url works just fine. This reverts commit 99c03a88cb6fed0519efdfaac305794653a12542. SVN-Revision: 48384
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index b51b12d482..9eca57af63 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=23
+PKG_VERSION:=22
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index 05471db14b..59747a3783 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -108,7 +108,7 @@ proto_6in4_setup() {
fi
}
- local url="$http://$username:$password@ipv4.tunnelbroker.net/nic/update?hostname=$tunnelid"
+ local url="$http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"
local try=0
local max=3