summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-07-05 09:07:16 +0200
committerJohn Crispin <john@phrozen.org>2016-07-05 22:59:14 +0200
commit8fe69e4d427b8ab90e591ba7abf28ed974b37f74 (patch)
tree2b5ca0f073cd6a66c66cca26f51619e393c1d999
parent9a4345069fb6a43419deaf37f1f01482eebe8466 (diff)
downloadmaster-31e0f0ae-8fe69e4d427b8ab90e591ba7abf28ed974b37f74.tar.gz
master-31e0f0ae-8fe69e4d427b8ab90e591ba7abf28ed974b37f74.tar.bz2
master-31e0f0ae-8fe69e4d427b8ab90e591ba7abf28ed974b37f74.zip
ar71xx: fix nand device profile
Signed-off-by: John Crispin <john@phrozen.org>
-rw-r--r--target/linux/ar71xx/image/Makefile1
-rw-r--r--target/linux/ar71xx/image/legacy-devices.mk18
-rw-r--r--target/linux/ar71xx/image/legacy.mk1
-rw-r--r--target/linux/ar71xx/image/nand.mk18
4 files changed, 19 insertions, 19 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ced1610aa6..cf0c605076 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -20,6 +20,7 @@ ifeq ($(SUBTARGET),generic)
include ./tp-link.mk
include ./ubnt.mk
include ./generic.mk
+include ./legacy-devices.mk
endif
ifeq ($(SUBTARGET),nand)
include ./nand.mk
diff --git a/target/linux/ar71xx/image/legacy-devices.mk b/target/linux/ar71xx/image/legacy-devices.mk
index 07d3df6831..f5519f7787 100644
--- a/target/linux/ar71xx/image/legacy-devices.mk
+++ b/target/linux/ar71xx/image/legacy-devices.mk
@@ -629,21 +629,3 @@ define LegacyDevice/NBG_460N_550N_550NH
DEVICE_PACKAGES := kmod-rtc-pcf8563
endef
LEGACY_DEVICES += NBG_460N_550N_550NH
-
-define LegacyDevice/R6100
- DEVICE_TITLE := NETGEAR R6100
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
-endef
-LEGACY_DEVICES += R6100
-
-define LegacyDevice/WNDR4300
- DEVICE_TITLE := NETGEAR WNDR3700v4/WNDR4300
- DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
-endef
-LEGACY_DEVICES += WNDR4300
-
-define LegacyDevice/NBG6716
- DEVICE_TITLE := Zyxel NBG 6716
- DEVICE_PACKAGES := kmod-rtc-pcf8563 kmod-ath10k
-endef
-LEGACY_DEVICES += NBG6716
diff --git a/target/linux/ar71xx/image/legacy.mk b/target/linux/ar71xx/image/legacy.mk
index 18eef4dd09..00c62e25fe 100644
--- a/target/linux/ar71xx/image/legacy.mk
+++ b/target/linux/ar71xx/image/legacy.mk
@@ -1,4 +1,3 @@
-include ./legacy-devices.mk
rootfs_type=$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))
# $(1): rootfs type.
diff --git a/target/linux/ar71xx/image/nand.mk b/target/linux/ar71xx/image/nand.mk
index 8e098b0d40..b46795896a 100644
--- a/target/linux/ar71xx/image/nand.mk
+++ b/target/linux/ar71xx/image/nand.mk
@@ -19,3 +19,21 @@ define Device/mr18
IMAGE/sysupgrade.tar := sysupgrade-nand
endef
TARGET_DEVICES += mr18
+
+define LegacyDevice/R6100
+ DEVICE_TITLE := NETGEAR R6100
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+LEGACY_DEVICES += R6100
+
+define LegacyDevice/WNDR4300
+ DEVICE_TITLE := NETGEAR WNDR3700v4/WNDR4300
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+LEGACY_DEVICES += WNDR4300
+
+define LegacyDevice/NBG6716
+ DEVICE_TITLE := Zyxel NBG 6716
+ DEVICE_PACKAGES := kmod-rtc-pcf8563 kmod-ath10k
+endef
+LEGACY_DEVICES += NBG6716