summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-03-10 08:43:40 +0000
committerSteven Barth <cyrus@openwrt.org>2015-03-10 08:43:40 +0000
commit853a1d4baf165cba8a9f4e9c5aa01581ab8ff412 (patch)
tree9c07ad800a4079fc240d9356ef35ad8cca1b652e
parenta7f198b12cdafaa515a59d323d627893b4337e16 (diff)
downloadmaster-31e0f0ae-853a1d4baf165cba8a9f4e9c5aa01581ab8ff412.tar.gz
master-31e0f0ae-853a1d4baf165cba8a9f4e9c5aa01581ab8ff412.tar.bz2
master-31e0f0ae-853a1d4baf165cba8a9f4e9c5aa01581ab8ff412.zip
6in4: make host dependency more specific
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 44635
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index ef9691227a..21e69e6f49 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=20
+PKG_VERSION:=21
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index f8a43ce24b..0289df3031 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -36,7 +36,7 @@ proto_6in4_setup() {
return
}
- ( proto_add_host_dependency "$cfg" 0.0.0.0 )
+ ( proto_add_host_dependency "$cfg" "$peeraddr" )
[ -z "$ipaddr" ] && {
local wanif