summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-07 13:33:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-07 13:33:15 +0000
commit84c6ee610bb8daf1933311ddf0628b8c74cf452f (patch)
tree30eb7077901f8d22a81ad25090276f8f8ca5d825
parent834417623de8f3c23ba1c231b6e078d5091e040c (diff)
downloadmaster-31e0f0ae-84c6ee610bb8daf1933311ddf0628b8c74cf452f.tar.gz
master-31e0f0ae-84c6ee610bb8daf1933311ddf0628b8c74cf452f.tar.bz2
master-31e0f0ae-84c6ee610bb8daf1933311ddf0628b8c74cf452f.zip
6in4: don't use /dev/stdout for wget calls
Busybox ash does not implement /dev/stdout, therfore any wget output is written into a file /dev/stdout instead of onto the standard output. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44301
-rw-r--r--package/network/ipv6/6in4/Makefile4
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh6
2 files changed, 5 insertions, 5 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index aeb187cb58..0dc1068b3f 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010-2014 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=18
+PKG_VERSION:=19
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index f639a5de8e..00b6e3550d 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -1,6 +1,6 @@
#!/bin/sh
# 6in4.sh - IPv6-in-IPv4 tunnel backend
-# Copyright (c) 2010-2014 OpenWrt.org
+# Copyright (c) 2010-2015 OpenWrt.org
[ -n "$INCLUDE_ONLY" ] || {
. /lib/functions.sh
@@ -68,7 +68,7 @@ proto_6in4_setup() {
local http="http"
local urlget="wget"
- local urlget_opts="-qO/dev/stdout"
+ local urlget_opts="-qO-"
local ca_path="${SSL_CERT_DIR-/etc/ssl/certs}"
if [ -n "$(which curl)" ]; then
@@ -82,7 +82,7 @@ proto_6in4_setup() {
if [ "$http" = "http" ] &&
wget --version 2>&1 | grep -qF "+https"; then
urlget="wget"
- urlget_opts="-qO/dev/stdout --ca-directory=$ca_path"
+ urlget_opts="-qO- --ca-directory=$ca_path"
http="https"
fi
[ "$http" = "https" -a -z "$(find $ca_path -name "*.0" 2>/dev/null)" ] && {