summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-09-21 21:15:41 +0000
committerSteven Barth <cyrus@openwrt.org>2015-09-21 21:15:41 +0000
commit836d462b10e82a3314e62bb5d15a1632e5786271 (patch)
tree2ac6498c365f19c140284d2f9bb9978f8fab5bd2
parentce59fe6b3d7ec186a12cf784038cc192a8eb9d4f (diff)
downloadmaster-31e0f0ae-836d462b10e82a3314e62bb5d15a1632e5786271.tar.gz
master-31e0f0ae-836d462b10e82a3314e62bb5d15a1632e5786271.tar.bz2
master-31e0f0ae-836d462b10e82a3314e62bb5d15a1632e5786271.zip
package: Remove dependencies to kmod-ipv6
Since r46834, IPv6 support is builtin if selected. Therefor, dependencies on kmod-ipv6 can no longer be fulfilled, since it is not a module anymore. Signed-off-by: Arjen de Korte <arjen+openwrt@de-korte.org> SVN-Revision: 47022
-rw-r--r--package/kernel/linux/modules/netfilter.mk6
-rw-r--r--package/network/config/gre/Makefile2
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rw-r--r--package/network/ipv6/6rd/Makefile2
-rw-r--r--package/network/ipv6/6to4/Makefile2
-rw-r--r--package/network/ipv6/ds-lite/Makefile2
-rw-r--r--package/network/ipv6/map/Makefile2
-rw-r--r--package/network/ipv6/odhcp6c/Makefile2
-rw-r--r--package/network/services/dnsmasq/Makefile2
-rw-r--r--package/network/utils/xtables-addons/Makefile2
10 files changed, 12 insertions, 12 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 3a436ac0c5..e21895d417 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -80,7 +80,7 @@ define KernelPackage/nf-conntrack6
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter IPv6 connection tracking
KCONFIG:=$(KCONFIG_NF_CONNTRACK6)
- DEPENDS:=+kmod-ipv6 +kmod-nf-conntrack
+ DEPENDS:=@IPV6 +kmod-nf-conntrack
FILES:=$(foreach mod,$(NF_CONNTRACK6-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(NF_CONNTRACK6-m)))
endef
@@ -454,7 +454,7 @@ $(eval $(call KernelPackage,ipt-led))
define KernelPackage/ipt-tproxy
TITLE:=Transparent proxying support
- DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-ipv6 +IPV6:kmod-ip6tables
+ DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-ip6tables
KCONFIG:= \
CONFIG_NETFILTER_TPROXY \
CONFIG_NETFILTER_XT_MATCH_SOCKET \
@@ -473,7 +473,7 @@ $(eval $(call KernelPackage,ipt-tproxy))
define KernelPackage/ipt-tee
TITLE:=TEE support
- DEPENDS:=+kmod-ipt-conntrack +IPV6:kmod-ipv6
+ DEPENDS:=+kmod-ipt-conntrack
KCONFIG:= \
CONFIG_NETFILTER_XT_TARGET_TEE
FILES:= \
diff --git a/package/network/config/gre/Makefile b/package/network/config/gre/Makefile
index 217c276945..49e7d1932a 100644
--- a/package/network/config/gre/Makefile
+++ b/package/network/config/gre/Makefile
@@ -42,7 +42,7 @@ endef
define Package/grev6
$(call Package/gre/Default)
TITLE:=Generic Routing Encapsulation (IPv6) config support
- DEPENDS:=@(PACKAGE_gre) +kmod-ipv6 +kmod-ip6-gre
+ DEPENDS:=@(PACKAGE_gre) @IPV6 +kmod-ip6-gre
endef
define Package/grev6/description
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index b7c2da725c..2ffdfc0e95 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/6in4
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+kmod-ipv6 +kmod-sit
+ DEPENDS:=@IPV6 +kmod-sit
TITLE:=IPv6-in-IPv4 configuration support
MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
PKGARCH:=all
diff --git a/package/network/ipv6/6rd/Makefile b/package/network/ipv6/6rd/Makefile
index cde711771c..04d607eb9e 100644
--- a/package/network/ipv6/6rd/Makefile
+++ b/package/network/ipv6/6rd/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/6rd
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+kmod-ipv6 +kmod-sit
+ DEPENDS:=@IPV6 +kmod-sit
TITLE:=6rd configuration support
MAINTAINER:=Steven Barth <cyrus@openwrt.org>
PKGARCH:=all
diff --git a/package/network/ipv6/6to4/Makefile b/package/network/ipv6/6to4/Makefile
index fcec90de0b..20605f6588 100644
--- a/package/network/ipv6/6to4/Makefile
+++ b/package/network/ipv6/6to4/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/6to4
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+kmod-ipv6 +kmod-sit
+ DEPENDS:=@IPV6 +kmod-sit
TITLE:=IPv6-to-IPv4 configuration support
MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
PKGARCH:=all
diff --git a/package/network/ipv6/ds-lite/Makefile b/package/network/ipv6/ds-lite/Makefile
index 8c22c46a15..919ac7e74d 100644
--- a/package/network/ipv6/ds-lite/Makefile
+++ b/package/network/ipv6/ds-lite/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/ds-lite
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+kmod-ipv6 +kmod-ip6-tunnel +resolveip
+ DEPENDS:=@IPV6 +kmod-ip6-tunnel +resolveip
TITLE:=Dual-Stack Lite (DS-Lite) configuration support
MAINTAINER:=Steven Barth <steven@midlink.org>
PKGARCH:=all
diff --git a/package/network/ipv6/map/Makefile b/package/network/ipv6/map/Makefile
index f6f2cd6fde..af6f75874f 100644
--- a/package/network/ipv6/map/Makefile
+++ b/package/network/ipv6/map/Makefile
@@ -18,7 +18,7 @@ include $(INCLUDE_DIR)/cmake.mk
define Package/map
SECTION:=net
CATEGORY:=Network
- DEPENDS:=+kmod-ipv6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra
+ DEPENDS:=@IPV6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra
TITLE:=MAP-E and Lightweight 4over6 configuration support
MAINTAINER:=Steven Barth <steven@midlink.org>
endef
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 7c88d59f5c..0b38be93cd 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -30,7 +30,7 @@ define Package/odhcp6c
SECTION:=net
CATEGORY:=Network
TITLE:=Embedded DHCPv6-client for OpenWrt
- DEPENDS:=+kmod-ipv6
+ DEPENDS:=@IPV6
endef
define Package/odhcp6c/config
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index bf9d0a6273..cddde5c0a2 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -44,7 +44,7 @@ endef
define Package/dnsmasq-dhcpv6
$(call Package/dnsmasq/Default)
TITLE += (with DHCPv6 support)
- DEPENDS:=@IPV6 +kmod-ipv6
+ DEPENDS:=@IPV6
VARIANT:=dhcpv6
endef
diff --git a/package/network/utils/xtables-addons/Makefile b/package/network/utils/xtables-addons/Makefile
index 8f54ee3bb5..ff6466fe9f 100644
--- a/package/network/utils/xtables-addons/Makefile
+++ b/package/network/utils/xtables-addons/Makefile
@@ -147,6 +147,6 @@ $(eval $(call BuildTemplate,lua,Lua PacketScript,xt_LUA,LUA/xt_LUA,+kmod-ipt-con
$(eval $(call BuildTemplate,psd,psd,xt_psd,xt_psd,))
$(eval $(call BuildTemplate,quota2,quota2,xt_quota2,xt_quota2,))
$(eval $(call BuildTemplate,sysrq,SYSRQ,xt_SYSRQ,xt_SYSRQ,+kmod-ipt-compat-xtables))
-$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,+kmod-ipt-compat-xtables +IPV6:kmod-ipv6))
+$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,+kmod-ipt-compat-xtables))
$(eval $(call BuildPackage,iptaccount))