summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-10 22:37:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-10 22:37:28 +0000
commit8243f3c1b1143f5cba019a7a2ee21394abdd540c (patch)
treea1f1dd53cbaab976c0412151b8798a865327469f
parent92bfc02547a7672fa744314f6efe513744e2a9df (diff)
downloadmaster-31e0f0ae-8243f3c1b1143f5cba019a7a2ee21394abdd540c.tar.gz
master-31e0f0ae-8243f3c1b1143f5cba019a7a2ee21394abdd540c.tar.bz2
master-31e0f0ae-8243f3c1b1143f5cba019a7a2ee21394abdd540c.zip
fix ar7 image installation (patch by sw, fixes #2197)
SVN-Revision: 8393
-rw-r--r--target/linux/ar7-2.6/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar7-2.6/image/Makefile b/target/linux/ar7-2.6/image/Makefile
index 33324cd365..27af165533 100644
--- a/target/linux/ar7-2.6/image/Makefile
+++ b/target/linux/ar7-2.6/image/Makefile
@@ -64,7 +64,7 @@ endef
define Image/Build
dd if=$(KDIR)/loader.bin $(call align/$(1)) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
- cat $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
+ cat $(KDIR)/root.$(1) >> $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
$(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin)
$(call Image/Build/CyberTAN,$(1),AG1B,AG1B,$(1))
$(call Image/Build/CyberTAN,$(1),WA21,WA21,$(1))