summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-01-23 16:39:31 +0000
committerNicolas Thill <nico@openwrt.org>2010-01-23 16:39:31 +0000
commit815dc97a587ca8d78ca7e08b2326b0b68ddafd92 (patch)
tree377681dca02d58055816217917937498636e68ef
parent8499c45a7355570239f1d54b05803f42a8989644 (diff)
downloadmaster-31e0f0ae-815dc97a587ca8d78ca7e08b2326b0b68ddafd92.tar.gz
master-31e0f0ae-815dc97a587ca8d78ca7e08b2326b0b68ddafd92.tar.bz2
master-31e0f0ae-815dc97a587ca8d78ca7e08b2326b0b68ddafd92.zip
add explicit dependency on kmod-crypto-core when required (closes: #6557)
SVN-Revision: 19291
-rw-r--r--package/kernel/modules/netsupport.mk2
-rw-r--r--package/kernel/modules/wireless.mk4
-rw-r--r--package/mac80211/Makefile2
-rw-r--r--package/ubsec_ssb/Makefile2
4 files changed, 5 insertions, 5 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 5b58aae034..e19afcc03f 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -505,7 +505,7 @@ $(eval $(call KernelPackage,ipoa))
define KernelPackage/mppe
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Microsoft PPP compression/encryption
- DEPENDS:=kmod-ppp +kmod-crypto-arc4 +kmod-crypto-sha1
+ DEPENDS:=kmod-ppp +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-sha1
KCONFIG:= \
CONFIG_PPP_MPPE_MPPC \
CONFIG_PPP_MPPE
diff --git a/package/kernel/modules/wireless.mk b/package/kernel/modules/wireless.mk
index 19f07408c1..25e2286f16 100644
--- a/package/kernel/modules/wireless.mk
+++ b/package/kernel/modules/wireless.mk
@@ -12,7 +12,7 @@ WIRELESS_MENU:=Wireless Drivers
define KernelPackage/ieee80211
SUBMENU:=$(WIRELESS_MENU)
TITLE:=802.11 Networking stack
- DEPENDS:=+kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic @LINUX_2_4||@LINUX_2_6_21||LINUX_2_6_25
+ DEPENDS:=+kmod-crypto-core kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic @LINUX_2_4||@LINUX_2_6_21||LINUX_2_6_25
KCONFIG:= \
CONFIG_IEEE80211 \
CONFIG_IEEE80211_CRYPT_WEP \
@@ -83,7 +83,7 @@ $(eval $(call KernelPackage,lib80211))
define KernelPackage/net-libipw
SUBMENU:=$(WIRELESS_MENU)
TITLE:=libipw for ipw2100 and ipw2200
- DEPENDS:=@PCI_SUPPORT +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic +kmod-lib80211 @LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32
+ DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic +kmod-lib80211 @LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32
KCONFIG:=CONFIG_LIBIPW
FILES:=$(LINUX_DIR)/drivers/net/wireless/ipw2x00/libipw.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,49,libipw)
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 0d0e975b9a..c907fb1bc5 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -39,7 +39,7 @@ endef
define KernelPackage/mac80211
$(call KernelPackage/mac80211/Default)
TITLE:=Linux 802.11 Wireless Networking Stack
- DEPENDS+= +kmod-crypto-arc4 +kmod-crypto-aes +wireless-tools +iw @!LINUX_2_6_21 @!LINUX_2_6_25
+ DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +wireless-tools +iw @!LINUX_2_6_21 @!LINUX_2_6_25
FILES:= \
$(PKG_BUILD_DIR)/compat/compat.$(LINUX_KMOD_SUFFIX) \
$(PKG_BUILD_DIR)/compat/compat_firmware_class.$(LINUX_KMOD_SUFFIX) \
diff --git a/package/ubsec_ssb/Makefile b/package/ubsec_ssb/Makefile
index 0a0e5606eb..9c108d1ca7 100644
--- a/package/ubsec_ssb/Makefile
+++ b/package/ubsec_ssb/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/ocf-ubsec-ssb
SUBMENU:=$(CRYPTO_MENU)
- DEPENDS:=@TARGET_brcm47xx +kmod-crypto-ocf
+ DEPENDS:=@TARGET_brcm47xx +kmod-crypto-core +kmod-crypto-ocf
TITLE:=BCM5365P IPSec Core driver
FILES:=$(PKG_BUILD_DIR)/src/ubsec_ssb.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,09,ubsec_ssb)