summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
commit800ef0f56ca5971811267b5639c7895c2d569491 (patch)
tree4223d1f8eb3174463a4f20bc90c8e68d6eb13b19
parentbb402acf616778e36b0d0b24c71167407875fea5 (diff)
downloadmaster-31e0f0ae-800ef0f56ca5971811267b5639c7895c2d569491.tar.gz
master-31e0f0ae-800ef0f56ca5971811267b5639c7895c2d569491.tar.bz2
master-31e0f0ae-800ef0f56ca5971811267b5639c7895c2d569491.zip
some minor fixes, cleanups, package build abstraction
SVN-Revision: 9051
-rw-r--r--include/package-ipkg.mk5
-rw-r--r--include/package.mk11
-rw-r--r--include/prereq.mk4
-rw-r--r--include/quilt.mk4
-rw-r--r--include/target.mk8
5 files changed, 23 insertions, 9 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index f75c0a23f3..16378a0f0e 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -23,7 +23,7 @@ define BuildIPKGVariable
endef
ifeq ($(DUMP),)
- define BuildIPKG
+ define BuildTarget/ipkg
IPKG_$(1):=$(PACKAGE_DIR)/$(1)_$(VERSION)_$(PKGARCH).ipk
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg/$(1)
INFO_$(1):=$(IPKG_STATE_DIR)/info/$(1).list
@@ -92,9 +92,6 @@ ifeq ($(DUMP),)
$(PKG_BUILD_DIR)/.version-$(1)_$(VERSION)_$(PKGARCH): $(STAMP_PREPARED)
-@rm -f $(PKG_BUILD_DIR)/.version-$(1)_* 2>/dev/null
@touch $$@
-
- $$(eval $$(call Build/DefaultTargets,$(1)))
-
endef
$(STAGING_DIR)/etc/ipkg.conf:
diff --git a/include/package.mk b/include/package.mk
index 43d0663f60..9090455658 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -97,8 +97,15 @@ endif
$(call shexport,Package/$(1)/description)
$(call shexport,Package/$(1)/config)
- $(Dumpinfo)
- $(BuildIPKG)
+ $(if $(DUMP), \
+ $(Dumpinfo), \
+ $(foreach target, \
+ $(if $(Package/$(1)/targets),$(Package/$(1)/targets), \
+ $(if $(PKG_TARGETS),$(PKG_TARGETS), ipkg ) \
+ ), $(BuildTarget/$(target)) \
+ ) \
+ )
+ $(if $(DUMP),,$(call Build/DefaultTargets,$(1)))
endef
# prevent libtool from setting rpath when linking
diff --git a/include/prereq.mk b/include/prereq.mk
index 8e5490ccff..4a55c89ffc 100644
--- a/include/prereq.mk
+++ b/include/prereq.mk
@@ -5,6 +5,9 @@
# See /LICENSE for more information.
#
+ifneq ($(__prereq_inc),1)
+__prereq_inc:=1
+
prereq:
if [ -f $(TMP_DIR)/.prereq-error ]; then \
echo; \
@@ -15,6 +18,7 @@ prereq:
fi
.SILENT: prereq
+endif
define Require
export PREREQ_CHECK=1
diff --git a/include/quilt.mk b/include/quilt.mk
index a7aac91c06..4dce2a6d8c 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -5,6 +5,9 @@
# See /LICENSE for more information.
#
+ifneq ($(__quilt_inc),1)
+__quilt_inc:=1
+
ifeq ($(TARGET_BUILD),1)
PKG_BUILD_DIR:=$(LINUX_DIR)
endif
@@ -134,3 +137,4 @@ refresh: quilt-check
update: quilt-check
$(if $(KERNEL_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
+endif
diff --git a/include/target.mk b/include/target.mk
index c8eb76c254..1590b91091 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -75,9 +75,11 @@ define Profile
endif
endef
--include $(PLATFORM_DIR)/profiles/*.mk
-ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
- -include $(PLATFORM_SUBDIR)/profiles/*.mk
+ifeq ($(DUMP)$(if $(TARGET_BUILD),,1),)
+ -include $(PLATFORM_DIR)/profiles/*.mk
+ ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ -include $(PLATFORM_SUBDIR)/profiles/*.mk
+ endif
endif
$(eval $(call shexport,Target/Description))