summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-30 22:43:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-30 22:43:25 +0000
commit761dc0a0aea048ef228635a271ef6d3daf0d0518 (patch)
tree03331e3489694b00957056e8263d9363bcde76ba
parent82914583a98af72e6e117e3ca2feffdf532e3eb5 (diff)
downloadmaster-31e0f0ae-761dc0a0aea048ef228635a271ef6d3daf0d0518.tar.gz
master-31e0f0ae-761dc0a0aea048ef228635a271ef6d3daf0d0518.tar.bz2
master-31e0f0ae-761dc0a0aea048ef228635a271ef6d3daf0d0518.zip
fix a dependency bug
SVN-Revision: 8561
-rw-r--r--include/subdir.mk2
-rw-r--r--package/Makefile15
-rw-r--r--target/Makefile8
3 files changed, 9 insertions, 16 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index 0a3eff307e..40a06ed9e1 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -38,7 +38,7 @@ endef
define stampfile
$(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build
- @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) || \
+ @+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
@mkdir -p $$$$(dirname $$($(1)/stamp-$(3)))
@touch $$($(1)/stamp-$(3))
diff --git a/package/Makefile b/package/Makefile
index 38b650c09a..38e39da293 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -40,15 +40,10 @@ $(curdir)/index: FORCE
$(curdir)/flags-install:= -j1
-$(eval $(call stampfile,$(curdir),package,prereq))
-$(eval $(call stampfile,$(curdir),package,cleanup))
-$(eval $(call stampfile,$(curdir),package,compile))
-$(eval $(call stampfile,$(curdir),package,install))
-$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
-
-$($(curdir)/stamp-cleanup): $(TMP_DIR)/.build
-$($(curdir)/stamp-compile): $($(curdir)/stamp-cleanup) $(TMP_DIR)/.build
-$($(curdir)/stamp-install): $($(curdir)/stamp-compile) $(TMP_DIR)/.build
-$($(curdir)/stamp-rootfs-prepare): $($(curdir)/stamp-install) $(TMP_DIR)/.build
+$(eval $(call stampfile,$(curdir),package,prereq,.config))
+$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare,$(TMP_DIR)/.build))
$(eval $(call subdir,$(curdir)))
diff --git a/target/Makefile b/target/Makefile
index b98cd96bf0..3d36d26718 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -12,12 +12,10 @@ $(curdir)/builddirs-install:=linux $(if $(CONFIG_SDK),sdk) $(if $(CONFIG_IB),ima
$(curdir)/imagebuilder/prepare:=$(curdir)/linux/install
-$(eval $(call stampfile,$(curdir),target,prereq))
-$(eval $(call stampfile,$(curdir),target,compile))
-$(eval $(call stampfile,$(curdir),target,install))
+$(eval $(call stampfile,$(curdir),target,prereq,.config))
+$(eval $(call stampfile,$(curdir),target,compile,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),target,install,$(TMP_DIR)/.build))
-$($(curdir)/stamp-prereq): .config
-$($(curdir)/stamp-compile): $(TMP_DIR)/.build
$($(curdir)/stamp-install): $($(curdir)/stamp-compile)
$(eval $(call subdir,$(curdir)))