summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-08-17 05:59:12 +0000
committerJohn Crispin <john@openwrt.org>2015-08-17 05:59:12 +0000
commit66f6c9e231224ef32f70142d3f1294b83b7cebba (patch)
tree0c05d6b7288204866cd15e6d892cc0d1165f88bb
parent102073ca17b91c079cd150be0feb30796721f6da (diff)
downloadmaster-31e0f0ae-66f6c9e231224ef32f70142d3f1294b83b7cebba.tar.gz
master-31e0f0ae-66f6c9e231224ef32f70142d3f1294b83b7cebba.tar.bz2
master-31e0f0ae-66f6c9e231224ef32f70142d3f1294b83b7cebba.zip
ramips: fix Sitecom WL-341v3 board and image names
The following patch changes: * board name from "wl341v3" to "wl-341v3" * dts filename * LED names in dts file for Sitecom WL-341v3 device. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com> SVN-Revision: 46622
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh2
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh2
-rw-r--r--target/linux/ramips/dts/WL-341V3.dts (renamed from target/linux/ramips/dts/WL341V3.dts)16
-rw-r--r--target/linux/ramips/image/Makefile10
4 files changed, 15 insertions, 15 deletions
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index d25fa3adc6..aff380b5d4 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -335,7 +335,7 @@ ramips_board_detect() {
name="whr-g300n"
;;
*"Sitecom WL-341 v3")
- name="wl341v3"
+ name="wl-341v3"
;;
*"Sitecom WL-351 v1 002")
name="wl-351"
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index f46155ff43..f78bc22822 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -109,7 +109,7 @@ platform_check_image() {
wl-330n | \
wl-330n3g | \
wl-351 | \
- wl341v3 | \
+ wl-341v3 | \
wli-tx4-ag300n | \
wzr-agl300nh | \
wmr300 |\
diff --git a/target/linux/ramips/dts/WL341V3.dts b/target/linux/ramips/dts/WL-341V3.dts
index 40ce630460..ce5e820526 100644
--- a/target/linux/ramips/dts/WL341V3.dts
+++ b/target/linux/ramips/dts/WL-341V3.dts
@@ -3,7 +3,7 @@
/include/ "rt3050.dtsi"
/ {
- compatible = "WL341V3", "ralink,rt3052-soc";
+ compatible = "WL-341V3", "ralink,rt3052-soc";
model = "Sitecom WL-341 v3";
cfi@1f000000 {
@@ -63,37 +63,37 @@
compatible = "gpio-leds";
first {
- label = "wl341v3:amber:first";
+ label = "wl-341v3:amber:first";
gpios = <&gpio0 9 1>;
};
first2 {
- label = "wl341v3:blue:first";
+ label = "wl-341v3:blue:first";
gpios = <&gpio0 13 1>;
};
third {
- label = "wl341v3:amber:third";
+ label = "wl-341v3:amber:third";
gpios = <&gpio0 11 1>;
};
third2 {
- label = "wl341v3:blue:third";
+ label = "wl-341v3:blue:third";
gpios = <&gpio0 14 1>;
};
fourth {
- label = "wl341v3:blue:fourth";
+ label = "wl-341v3:blue:fourth";
gpios = <&gpio0 10 1>;
};
fifth {
- label = "wl341v3:amber:fifth";
+ label = "wl-341v3:amber:fifth";
gpios = <&gpio0 12 1>;
};
fifth2 {
- label = "wl341v3:blue:fifth";
+ label = "wl-341v3:blue:fifth";
gpios = <&gpio0 8 1>;
};
};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 78fffcd6e6..af09f2735f 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -637,8 +637,8 @@ Image/Build/Profile/WL-330N3G=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n3g
kernel_size_wl341v3=917504
rootfs_size_wl341v3=2949120
-define BuildFirmware/WL341V3/squashfs
- $(call BuildFirmware/Default4M/$(1),$(1),wl341v3,WL341V3)
+define BuildFirmware/WL-341V3/squashfs
+ $(call BuildFirmware/Default4M/$(1),$(1),wl-341v3,WL-341V3)
# This code looks broken and really needs to be converted to C
if [ -e "$(call sysupname,$(1),$(2))" ]; then \
( \
@@ -654,8 +654,8 @@ define BuildFirmware/WL341V3/squashfs
) > $(call imgname,$(1),$(2))-factory.bin; \
fi
endef
-BuildFirmware/WL341V3/initramfs=$(call BuildFirmware/OF/initramfs,$(1),wl341v3,WL341V3)
-Image/Build/Profile/WL341V3=$(call BuildFirmware/WL341V3/$(1),$(1))
+BuildFirmware/WL-341V3/initramfs=$(call BuildFirmware/OF/initramfs,$(1),wl-341v3,WL-341V3)
+Image/Build/Profile/WL-341V3=$(call BuildFirmware/WL-341V3/$(1),$(1))
Image/Build/Profile/WL-351=$(call BuildFirmware/Default4M/$(1),$(1),wl-351,WL-351)
@@ -765,7 +765,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/WIZARD8800,$(1))
$(call Image/Build/Profile/WL-330N,$(1))
$(call Image/Build/Profile/WL-330N3G,$(1))
- $(call Image/Build/Profile/WL341V3,$(1))
+ $(call Image/Build/Profile/WL-341V3,$(1))
$(call Image/Build/Profile/WL-351,$(1))
$(call Image/Build/Profile/WNCE2001,$(1))
$(call Image/Build/Profile/WR512-3GN,$(1))