summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-22 10:47:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-22 10:47:26 +0000
commit4fde9deed11f56b65f389c7e83c70b7b5878222e (patch)
tree0199963daae2c1aeff8f86128c8ecf54de4a0fa8
parenta3618cd9c1796ae89937105101167902f1eb5e57 (diff)
downloadmaster-31e0f0ae-4fde9deed11f56b65f389c7e83c70b7b5878222e.tar.gz
master-31e0f0ae-4fde9deed11f56b65f389c7e83c70b7b5878222e.tar.bz2
master-31e0f0ae-4fde9deed11f56b65f389c7e83c70b7b5878222e.zip
Revert "build: use ONESHELL to speed up scanning and the toplevel makefile"
This seems to cause issues on some build hosts, and it is not that important. SVN-Revision: 43025
-rw-r--r--Makefile1
-rw-r--r--include/scan.mk1
-rw-r--r--include/target.mk1
3 files changed, 0 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index f75fc7fda4..91b6946ac3 100644
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,6 @@ empty:=
space:= $(empty) $(empty)
$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
-.ONESHELL:
world:
include $(TOPDIR)/include/host.mk
diff --git a/include/scan.mk b/include/scan.mk
index 2f2753f2a0..0998333439 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -78,4 +78,3 @@ $(TMP_DIR)/.$(SCAN_TARGET): $(TARGET_STAMP) $(SCAN_STAMP)
FORCE:
.PHONY: FORCE
.NOTPARALLEL:
-.ONESHELL:
diff --git a/include/target.mk b/include/target.mk
index 657109e75d..3401f849a5 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -19,7 +19,6 @@ DEFAULT_PACKAGES.bootloader:=
ifneq ($(DUMP),)
all: dumpinfo
- .ONESHELL:
endif
target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))