summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2016-05-29 00:41:30 +0200
committerAlexander Couzens <lynxis@fe80.eu>2016-06-02 21:58:10 +0200
commit49cf35671053758d8075a9d6f8bfe93d9112a0fa (patch)
treee376c0104bd64fed4bb3bf2eab87b9b6932033a3
parent9efbf583606a45659e97290c6e1a4168cfc367a4 (diff)
downloadmaster-31e0f0ae-49cf35671053758d8075a9d6f8bfe93d9112a0fa.tar.gz
master-31e0f0ae-49cf35671053758d8075a9d6f8bfe93d9112a0fa.tar.bz2
master-31e0f0ae-49cf35671053758d8075a9d6f8bfe93d9112a0fa.zip
kernel: add random-omap rng for omap
Kernel module for the OMAP Random Number Generator found on OMAP16xx, OMAP2/3/4/5 and AM33xx/AM43xx multimedia processors. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
-rw-r--r--package/kernel/linux/modules/other.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 98b7f54dcf..11d836e5f7 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -874,6 +874,21 @@ endef
$(eval $(call KernelPackage,random-core))
+define KernelPackage/random-omap
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Hardware Random Number Generator OMAP support
+ KCONFIG:=CONFIG_HW_RANDOM_OMAP
+ FILES:=$(LINUX_DIR)/drivers/char/hw_random/omap-rng.ko
+ DEPENDS:=@(TARGET_omap24xx||TARGET_omap) +kmod-random-core
+ AUTOLOAD:=$(call AutoProbe,random-omap)
+endef
+
+define KernelPackage/random-omap/description
+ Kernel module for the OMAP Random Number Generator
+ found on OMAP16xx, OMAP2/3/4/5 and AM33xx/AM43xx multimedia processors.
+endef
+
+$(eval $(call KernelPackage,random-omap))
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)