summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-11-24 20:41:18 +0000
committerJohn Crispin <john@openwrt.org>2015-11-24 20:41:18 +0000
commit41587675ecf23b4cc092c302666bf39ae277c21c (patch)
tree52411e82baaab2455121d1e00da43d232c707fbb
parent091b668f1a84e949d43e056c518ee69e55f41c44 (diff)
downloadmaster-31e0f0ae-41587675ecf23b4cc092c302666bf39ae277c21c.tar.gz
master-31e0f0ae-41587675ecf23b4cc092c302666bf39ae277c21c.tar.bz2
master-31e0f0ae-41587675ecf23b4cc092c302666bf39ae277c21c.zip
lantiq: ltq-vdsl-app: add dsl_cpe_pipe.sh
Signed-off-by: Hauke Mehrtens <hauke.mehrtens@lantiq.com> SVN-Revision: 47636
-rw-r--r--package/network/config/ltq-vdsl-app/Makefile4
-rwxr-xr-xpackage/network/config/ltq-vdsl-app/files/dsl_cpe_pipe.sh18
2 files changed, 21 insertions, 1 deletions
diff --git a/package/network/config/ltq-vdsl-app/Makefile b/package/network/config/ltq-vdsl-app/Makefile
index 250d6f7664..b069421596 100644
--- a/package/network/config/ltq-vdsl-app/Makefile
+++ b/package/network/config/ltq-vdsl-app/Makefile
@@ -54,7 +54,8 @@ CONFIGURE_ARGS += \
--disable-soap-support \
--enable-dsl-bonding=no \
--enable-debug-prints=err \
- --disable-dti
+ --disable-dti \
+ --enable-debug
ifeq ($(CONFIG_IFX_CLI),y)
CONFIGURE_ARGS += \
@@ -73,6 +74,7 @@ define Package/ltq-vdsl-app/install
$(INSTALL_BIN) ./files/vdsl_cpe_control_wrapper $(1)/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin/vdsl_cpe_control
+ $(INSTALL_BIN) ./files/dsl_cpe_pipe.sh $(1)/sbin/
endef
$(eval $(call BuildPackage,ltq-vdsl-app))
diff --git a/package/network/config/ltq-vdsl-app/files/dsl_cpe_pipe.sh b/package/network/config/ltq-vdsl-app/files/dsl_cpe_pipe.sh
new file mode 100755
index 0000000000..30393b281e
--- /dev/null
+++ b/package/network/config/ltq-vdsl-app/files/dsl_cpe_pipe.sh
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+pipe_no=0
+
+# use specified pipe no
+case "$1" in
+0|1|2)
+pipe_no=$1; shift; ;;
+esac
+
+
+#echo "Call dsl_pipe with $*"
+lock /var/lock/dsl_pipe
+echo $* > /tmp/pipe/dsl_cpe${pipe_no}_cmd
+result=`cat /tmp/pipe/dsl_cpe${pipe_no}_ack`
+lock -u /var/lock/dsl_pipe
+
+echo "$result"