summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-06-21 20:52:53 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-06-21 20:52:53 +0000
commit3f0f8d9c87cc53042f444a0c00c87df630092d31 (patch)
tree5c8455ee7d5020720245266ff9ff0c49d4df2acc
parenta9191c8b32520ae269d57cfd119b9e980b5249c8 (diff)
downloadmaster-31e0f0ae-3f0f8d9c87cc53042f444a0c00c87df630092d31.tar.gz
master-31e0f0ae-3f0f8d9c87cc53042f444a0c00c87df630092d31.tar.bz2
master-31e0f0ae-3f0f8d9c87cc53042f444a0c00c87df630092d31.zip
fix and make usable kmod-pcmcia-rsrc
This module is also needed for e.g: kmod-bcm63xx-pcmcia SVN-Revision: 27253
-rw-r--r--package/kernel/modules/pcmcia.mk37
-rw-r--r--target/linux/brcm63xx/modules.mk2
2 files changed, 24 insertions, 15 deletions
diff --git a/package/kernel/modules/pcmcia.mk b/package/kernel/modules/pcmcia.mk
index 468a62f0a0..e4df2aa395 100644
--- a/package/kernel/modules/pcmcia.mk
+++ b/package/kernel/modules/pcmcia.mk
@@ -28,28 +28,37 @@ endef
$(eval $(call KernelPackage,pcmcia-core))
-
-define KernelPackage/pcmcia-yenta
+define KernelPackage/pcmcia-rsrc
SUBMENU:=$(PCMCIA_MENU)
- TITLE:=yenta socket driver
+ TITLE:=PCMCIA resource support
DEPENDS:=kmod-pcmcia-core
- KCONFIG:= \
- CONFIG_PCCARD_NONSTATIC \
- CONFIG_YENTA
+ KCONFIG:=CONFIG_PCCARD_NONSTATIC=y
# For Linux 2.6.35+
ifneq ($(wildcard $(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko),)
- FILES:= \
- $(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko \
- $(LINUX_DIR)/drivers/pcmcia/yenta_socket.ko
- AUTOLOAD:=$(call AutoLoad,41,pcmcia_rsrc yenta_socket)
+ FILES:=$(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko
+ AUTOLOAD:=$(call AutoLoad,26,pcmcia_rsrc)
else
- FILES:= \
- $(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.ko \
- $(LINUX_DIR)/drivers/pcmcia/yenta_socket.ko
- AUTOLOAD:=$(call AutoLoad,41,rsrc_nonstatic yenta_socket)
+ FILES:=$(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.ko \
+ AUTOLOAD:=$(call AutoLoad,26,rsrc_nonstatic)
endif
endef
+define KernelPackage/pcmcia-rsrc/description
+ Kernel support for PCMCIA resource allocation
+endef
+
+$(eval $(call KernelPackage,pcmcia-rsrc))
+
+
+define KernelPackage/pcmcia-yenta
+ SUBMENU:=$(PCMCIA_MENU)
+ TITLE:=yenta socket driver
+ DEPENDS:=kmod-pcmcia-rsrc
+ KCONFIG:=CONFIG_YENTA
+ FILES:=$(LINUX_DIR)/drivers/pcmcia/yenta_socket.ko
+ AUTOLOAD:=$(call AutoLoad,41,pcmcia_rsrc yenta_socket)
+endef
+
$(eval $(call KernelPackage,pcmcia-yenta))
diff --git a/target/linux/brcm63xx/modules.mk b/target/linux/brcm63xx/modules.mk
index 845fb644a7..e48d298bf0 100644
--- a/target/linux/brcm63xx/modules.mk
+++ b/target/linux/brcm63xx/modules.mk
@@ -24,7 +24,7 @@ $(eval $(call KernelPackage,bcm63xx-spi))
define KernelPackage/pcmcia-bcm63xx
SUBMENU:=$(PCMCIA_MENU)
TITLE:=Broadcom BCM63xx PCMCIA support
- DEPENDS:=@TARGET_brcm63xx kmod-pcmcia-core
+ DEPENDS:=@TARGET_brcm63xx +kmod-pcmcia-rsrc
KCONFIG:=CONFIG_PCMCIA_BCM63XX
FILES:=$(LINUX_DIR)/drivers/pcmcia/bcm63xx_pcmcia.ko
AUTOLOAD:=$(call AutoLoad,41,bcm63xx_pcmcia)