summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@googlemail.com>2016-07-20 15:44:49 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-22 09:48:12 +0200
commit39f3408732df53e8671426c207f178ae0cf42d01 (patch)
treeb16f082b76a94781f61e76e57a4699a6898295cc
parente6a7e6ed25866a067f87abeb00354f03f0866223 (diff)
downloadmaster-31e0f0ae-39f3408732df53e8671426c207f178ae0cf42d01.tar.gz
master-31e0f0ae-39f3408732df53e8671426c207f178ae0cf42d01.tar.bz2
master-31e0f0ae-39f3408732df53e8671426c207f178ae0cf42d01.zip
ppc4xx: remove booke-wdt watchdog package
This patch gets rid of the booke watchdog kmod package. Instead the affected boards will enable it in their kernel configs. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
-rw-r--r--package/kernel/linux/modules/other.mk16
-rw-r--r--target/linux/mpc85xx/Makefile3
-rw-r--r--target/linux/mpc85xx/config-4.41
-rw-r--r--target/linux/ppc40x/config-3.181
-rw-r--r--target/linux/ppc44x/config-3.181
5 files changed, 4 insertions, 18 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index a1fce482ad..3f7a3ee1b1 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -514,22 +514,6 @@ endef
$(eval $(call KernelPackage,wdt-orion))
-define KernelPackage/booke-wdt
- SUBMENU:=$(OTHER_MENU)
- TITLE:=PowerPC Book-E Watchdog Timer
- DEPENDS:=@(TARGET_mpc85xx||TARGET_ppc40x||TARGET_ppc44x)
- KCONFIG:=CONFIG_BOOKE_WDT
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/booke_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,booke_wdt,1)
-endef
-
-define KernelPackage/booke-wdt/description
- Kernel module for PowerPC Book-E Watchdog Timer
-endef
-
-$(eval $(call KernelPackage,booke-wdt))
-
-
define KernelPackage/rtc-ds1307
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support
diff --git a/target/linux/mpc85xx/Makefile b/target/linux/mpc85xx/Makefile
index a32be907a9..efd48d7d41 100644
--- a/target/linux/mpc85xx/Makefile
+++ b/target/linux/mpc85xx/Makefile
@@ -25,8 +25,7 @@ endif
DEFAULT_PACKAGES += \
kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
- kmod-leds-gpio kmod-booke-wdt \
- swconfig kmod-ath9k wpad-mini
+ kmod-leds-gpio swconfig kmod-ath9k wpad-mini
define Target/Description
Build images for the Freescale MPC85xx based boards.
diff --git a/target/linux/mpc85xx/config-4.4 b/target/linux/mpc85xx/config-4.4
index 90bde4fbf0..06b88705d9 100644
--- a/target/linux/mpc85xx/config-4.4
+++ b/target/linux/mpc85xx/config-4.4
@@ -28,6 +28,7 @@ CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
CONFIG_AUDIT_ARCH=y
CONFIG_BOOKE=y
+CONFIG_BOOKE_WDT=y
CONFIG_BOUNCE=y
# CONFIG_BSC9131_RDB is not set
# CONFIG_BSC9132_QDS is not set
diff --git a/target/linux/ppc40x/config-3.18 b/target/linux/ppc40x/config-3.18
index bf59bf132f..85bbe0cb9b 100644
--- a/target/linux/ppc40x/config-3.18
+++ b/target/linux/ppc40x/config-3.18
@@ -25,6 +25,7 @@ CONFIG_ARCH_USE_BUILTIN_BSWAP=y
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
CONFIG_AUDIT_ARCH=y
+CONFIG_BOOKE_WDT=y
CONFIG_BOUNCE=y
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_CLONE_BACKWARDS=y
diff --git a/target/linux/ppc44x/config-3.18 b/target/linux/ppc44x/config-3.18
index b18edbf93f..842d898c70 100644
--- a/target/linux/ppc44x/config-3.18
+++ b/target/linux/ppc44x/config-3.18
@@ -31,6 +31,7 @@ CONFIG_AUDIT_ARCH=y
# CONFIG_BAMBOO is not set
# CONFIG_BLUESTONE is not set
CONFIG_BOOKE=y
+CONFIG_BOOKE_WDT=y
CONFIG_BOUNCE=y
CONFIG_CANYONLANDS=y
CONFIG_CC_OPTIMIZE_FOR_SIZE=y