summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-09-05 16:16:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-09-05 16:16:59 +0000
commit392888845c01b5fb150a003c935ad43e708c9406 (patch)
tree398e8a65a882a67c2bcf781c8940b8dfc6febcee
parent1c74711ec1358a2dead8d5268ad4d0e8376b5b8b (diff)
downloadmaster-31e0f0ae-392888845c01b5fb150a003c935ad43e708c9406.tar.gz
master-31e0f0ae-392888845c01b5fb150a003c935ad43e708c9406.tar.bz2
master-31e0f0ae-392888845c01b5fb150a003c935ad43e708c9406.zip
fix build error in tools on darwin on newer macs (patch by dirtyfreebooter)
SVN-Revision: 22934
-rw-r--r--include/host.mk5
-rw-r--r--tools/cloog/Makefile5
-rw-r--r--tools/gmp/Makefile5
-rw-r--r--tools/mpc/Makefile5
-rw-r--r--tools/ppl/Makefile5
5 files changed, 3 insertions, 22 deletions
diff --git a/include/host.mk b/include/host.mk
index 02365d9eab..8092e8db77 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -32,11 +32,12 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
HOST_OS=`uname`; \
case "$$HOST_OS" in \
Linux) HOST_ARCH=`uname -m`;; \
+ Darwin) HOST_ARCH=`uname -m`;; \
*) HOST_ARCH=`uname -p`;; \
esac; \
GNU_HOST_NAME=`gcc -dumpmachine`; \
- [ -n "$$GNU_HOST_NAME" ] || \
- GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+ [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" == "Darwin" ] && \
+ GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
echo "HOST_OS:=$$HOST_OS" > $@; \
echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \
diff --git a/tools/cloog/Makefile b/tools/cloog/Makefile
index 3bbf812fe9..29b4b73040 100644
--- a/tools/cloog/Makefile
+++ b/tools/cloog/Makefile
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
unexport CFLAGS
-ifeq ($(HOST_OS),Darwin)
- GNU_HOST_NAME:=
- HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
HOST_CONFIGURE_VARS += \
LIBS=-lstdc++
diff --git a/tools/gmp/Makefile b/tools/gmp/Makefile
index f375ada347..514187ce6e 100644
--- a/tools/gmp/Makefile
+++ b/tools/gmp/Makefile
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
unexport CFLAGS
-ifeq ($(HOST_OS),Darwin)
- GNU_HOST_NAME:=
- HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
HOST_CONFIGURE_ARGS += \
--enable-static \
--disable-shared \
diff --git a/tools/mpc/Makefile b/tools/mpc/Makefile
index 3898830c0b..8f8f07f1cc 100644
--- a/tools/mpc/Makefile
+++ b/tools/mpc/Makefile
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
unexport CFLAGS
-ifeq ($(HOST_OS),Darwin)
- GNU_HOST_NAME:=
- HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
HOST_CONFIGURE_ARGS += \
--enable-static \
--disable-shared \
diff --git a/tools/ppl/Makefile b/tools/ppl/Makefile
index c9c09c5125..7eea73f0b0 100644
--- a/tools/ppl/Makefile
+++ b/tools/ppl/Makefile
@@ -17,11 +17,6 @@ include $(INCLUDE_DIR)/host-build.mk
unexport CFLAGS
-ifeq ($(HOST_OS),Darwin)
- GNU_HOST_NAME:=
- HOST_CONFIGURE_ARGS:=$(filter-out --target= --build= --host=,$(HOST_CONFIGURE_ARGS))
-endif
-
HOST_CONFIGURE_ARGS += \
--enable-static \
--disable-shared