summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Yong <me@ndoo.sg>2016-05-11 00:17:54 +0800
committerJohn Crispin <john@phrozen.org>2016-05-12 03:29:35 +0200
commit374cae9e6fcaf4cf4de4f2095f3fec558da51df6 (patch)
treec6dfa75aeffb0061ce38702779a4e8fb07f6d466
parent9195d8da355d0d141ac02c9a5269452dc64ffd2d (diff)
downloadmaster-31e0f0ae-374cae9e6fcaf4cf4de4f2095f3fec558da51df6.tar.gz
master-31e0f0ae-374cae9e6fcaf4cf4de4f2095f3fec558da51df6.tar.bz2
master-31e0f0ae-374cae9e6fcaf4cf4de4f2095f3fec558da51df6.zip
ramips: add initial support for SamKnows SK-WB8
Signed-off-by: Andrew Yong <me@ndoo.sg>
-rw-r--r--package/boot/uboot-envtools/files/ramips3
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh1
-rwxr-xr-xtarget/linux/ramips/base-files/etc/init.d/bootcount11
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/SK-WB8.dts124
-rw-r--r--target/linux/ramips/image/mt7621.mk6
-rw-r--r--target/linux/ramips/mt7621/profiles/samknows.mk18
10 files changed, 171 insertions, 1 deletions
diff --git a/package/boot/uboot-envtools/files/ramips b/package/boot/uboot-envtools/files/ramips
index a759bcc597..9ad5974348 100644
--- a/package/boot/uboot-envtools/files/ramips
+++ b/package/boot/uboot-envtools/files/ramips
@@ -24,7 +24,8 @@ linkits7688d | \
wsr-600 | \
wsr-1166 | \
br6425 | \
-miwifi-nano)
+miwifi-nano | \
+sk-wb8)
ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x1000" "0x10000"
;;
esac
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 47e1e6a6a3..f2dc8adb3a 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -46,6 +46,7 @@ all0239-3g|\
hw550-3g|\
mofi3500-3gn|\
sap-g3200u3|\
+sk-wb8|\
wf-2881)
set_usb_led "$board:green:usb"
;;
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index e7826d48b0..985ce4b266 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -79,6 +79,7 @@ ramips_setup_interfaces()
pbr-m1|\
psg1208|\
sap-g3200u3|\
+ sk-wb8|\
wf-2881|\
whr-300hp2|\
whr-600d|\
@@ -307,6 +308,9 @@ ramips_setup_macs()
lan_mac=$(macaddr_setbit_la "$lan_mac")
wan_mac=$(mtd_get_mac_binary factory 32772)
;;
+ sk-wb8)
+ wan_mac=$(mtd_get_mac_binary factory 57350)
+ ;;
tew-691gr)
lan_mac=$(cat /sys/class/net/eth0/address)
wan_mac=$(macaddr_add "$lan_mac" 3)
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index c638d16a81..e432fa6a59 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -79,6 +79,7 @@ get_status_led() {
;;
awapn2403|\
dir-645|\
+ sk-wb8|\
wrh-300cr)
status_led="$board:green:wps"
;;
diff --git a/target/linux/ramips/base-files/etc/init.d/bootcount b/target/linux/ramips/base-files/etc/init.d/bootcount
new file mode 100755
index 0000000000..b93e3c96f1
--- /dev/null
+++ b/target/linux/ramips/base-files/etc/init.d/bootcount
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common
+. /lib/ramips.sh
+
+START=99
+
+start() {
+ local board=$(ramips_board_name)
+ if [ $board = "sk-wb8" ]; then
+ fw_setenv bootcount 0
+ fi
+}
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 0ac0f68bb5..9d5421b0a0 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -376,6 +376,9 @@ ramips_board_detect() {
*"RUT5XX")
name="rut5xx"
;;
+ *"SamKnows Whitebox 8")
+ name="sk-wb8"
+ ;;
*"SAP-G3200U3")
name="sap-g3200u3"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 86ea4a33bd..6036f73074 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -112,6 +112,7 @@ platform_check_image() {
rt-n56u|\
rut5xx|\
sap-g3200u3|\
+ sk-wb8|\
sl-r7205|\
tew-691gr|\
tew-692gr|\
diff --git a/target/linux/ramips/dts/SK-WB8.dts b/target/linux/ramips/dts/SK-WB8.dts
new file mode 100644
index 0000000000..bb1e38225a
--- /dev/null
+++ b/target/linux/ramips/dts/SK-WB8.dts
@@ -0,0 +1,124 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+/ {
+ compatible = "mediatek,mt7621-eval-board", "mediatek,mt7621-soc";
+ model = "SamKnows Whitebox 8";
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x8000000>;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ wps {
+ label = "sk-wb8:green:wps";
+ gpios = <&gpio1 14 1>;
+ };
+
+ usb {
+ label = "sk-wb8:green:usb";
+ gpios = <&gpio1 15 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ wps {
+ label = "wps";
+ gpios = <&gpio1 11 1>;
+ linux,code = <0x211>;
+ };
+ reset {
+ label = "reset";
+ gpios = <&gpio1 9 1>;
+ linux,code = <0x198>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0 0>;
+ linux,modalias = "m25p80";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+
+ partition@e30000 {
+ label = "recovery";
+ reg = <0xe30000 0x1d0000>;
+ };
+
+ };
+};
+
+&pcie {
+ status = "okay";
+
+ pcie0 {
+ mt76@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ device_type = "pci";
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ mediatek,2ghz = <0>;
+ };
+ };
+
+ pcie1 {
+ mt76@1,0 {
+ reg = <0x0000 0 0 0 0>;
+ device_type = "pci";
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ mediatek,5ghz = <0>;
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0xe000>;
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "uart2", "uart3", "rgmii2", "sdhci";
+ ralink,function = "gpio";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1b8d3dae87..a09f4abfbf 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -138,6 +138,12 @@ define Device/ubnt-erx
endef
TARGET_DEVICES += ubnt-erx
+define Device/sk-wb8
+ DTS := SK-WB8
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+endef
+TARGET_DEVICES += sk-wb8
+
# FIXME: is this still needed?
define Image/Prepare
#define Build/Compile
diff --git a/target/linux/ramips/mt7621/profiles/samknows.mk b/target/linux/ramips/mt7621/profiles/samknows.mk
new file mode 100644
index 0000000000..aa2e45e4d1
--- /dev/null
+++ b/target/linux/ramips/mt7621/profiles/samknows.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/SK-WB8
+ NAME:=SamKnows Whitebox 8
+ PACKAGES:=\
+ kmod-usb-core kmod-usb3 \
+ kmod-ledtrig-usbdev uboot-envtools
+endef
+
+define Profile/SK-WB8/Description
+ Package set compatible with the SamKnows Whitebox 8.
+endef
+$(eval $(call Profile,SK-WB8))