summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-16 21:19:18 +0000
committerJohn Crispin <john@openwrt.org>2015-02-16 21:19:18 +0000
commit361839151407c897bb1856bc66712a28dc7f0024 (patch)
tree284caad2ce76c6a7a53fdc095b000b4784c59174
parentf440414c55f770e02e3b6a4b827b7b3820fd9101 (diff)
downloadmaster-31e0f0ae-361839151407c897bb1856bc66712a28dc7f0024.tar.gz
master-31e0f0ae-361839151407c897bb1856bc66712a28dc7f0024.tar.bz2
master-31e0f0ae-361839151407c897bb1856bc66712a28dc7f0024.zip
ramips: Buffalo WZR-AGL300NH target support
I got work with this patch. Ethernet switch (includes VLAN), WiFi connected via PCIe, LEDs, buttons. In mtd partion map of DTS file, I renamed Linux firmware regions (kernel + root squashfs) to “firmware”because it allows kernel to split kernel and roots and rootfsdata. signed-off-by: ngc@ff.iij4u.or.jp —— —— SVN-Revision: 44470
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network6
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/WZR-AGL300NH.dts135
-rw-r--r--target/linux/ramips/image/Makefile3
5 files changed, 148 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index f298aa47af..7e9d8c984b 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -242,6 +242,12 @@ ramips_setup_interfaces()
ucidef_add_switch_vlan "switch1" "2" "4 6t"
;;
+ wzr-agl300nh)
+ ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
+ ucidef_add_switch "switch0" "1" "1"
+ ucidef_add_switch_vlan "switch0" "1" "1 2 3 4 5t"
+ ucidef_add_switch_vlan "switch0" "2" "0 5t"
+ ;;
*)
RT3X5X=`cat /proc/cpuinfo | egrep "(RT3.5|RT5350)"`
if [ -n "${RT3X5X}" ]; then
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index d31fbe4f98..39a0868727 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -168,6 +168,9 @@ get_status_led() {
wli-tx4-ag300n)
status_led="buffalo:blue:power"
;;
+ wzr-agl300nh)
+ status_led="buffalo:green:router"
+ ;;
wl-351)
status_led="wl-351:amber:power"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 356a0856c9..fffbe72cb8 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -100,6 +100,7 @@ platform_check_image() {
wl-351 | \
wl341v3 | \
wli-tx4-ag300n | \
+ wzr-agl300nh | \
wmr300 |\
wnce2001 | \
wr512-3gn |\
diff --git a/target/linux/ramips/dts/WZR-AGL300NH.dts b/target/linux/ramips/dts/WZR-AGL300NH.dts
new file mode 100644
index 0000000000..8e18e90be2
--- /dev/null
+++ b/target/linux/ramips/dts/WZR-AGL300NH.dts
@@ -0,0 +1,135 @@
+/dts-v1/;
+
+/include/ "rt2880.dtsi"
+
+/ {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "WZR-AGL300NH", "ralink,rt2880-soc";
+ model = "Buffalo WZR-AGL300NH";
+
+ palmbus@300000 {
+ gpio0: gpio@600 {
+ status = "okay";
+ };
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "uartlite", "mdio";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ cfi@1f000000 {
+ compatible = "cfi-flash";
+ reg = <0x1f000000 0x800000>;
+
+ bank-width = <2>;
+ device-width = <2>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "uboot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+ partition@30000 {
+ label = "uboot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x3b0000>;
+ };
+ };
+
+ ethernet@400000 {
+ status = "okay";
+ mtd-mac-address = <&factory 0x4>;
+
+ port@0 {
+ ralink,fixed-link = <1000 1 1 1>;
+ };
+
+ mdio-bus {
+ status = "okay";
+ phy0: ethernet-phy@0 {
+ phy-mode = "mii";
+ reg = <0>;
+ };
+ };
+ };
+
+ rtl8366s {
+ compatible = "realtek,rtl8366s";
+ gpio-sda = <&gpio0 1 0>;
+ gpio-sck = <&gpio0 2 0>;
+ };
+
+ wmac@480000 {
+ ralink,mtd-eeprom = <&factory 0>;
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <100>;
+ wps {
+ label = "wps";
+ gpios = <&gpio0 0 1>;
+ linux,code = <0x211>;
+ };
+ router {
+ label = "router_switch";
+ gpios = <&gpio0 7 0>;
+ linux,code = <0x100>;
+ };
+ reset {
+ label = "reset";
+ gpios = <&gpio0 9 1>;
+ linux,code = <0x198>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ router {
+ label = "buffalo:green:router";
+ gpios = <&gpio0 8 1>;
+ };
+ diag {
+ label = "buffalo:red:diag";
+ gpios = <&gpio0 12 1>;
+ };
+ security_g {
+ label = "buffalo:orange:security_g";
+ gpios = <&gpio0 11 1>;
+ };
+ security_n {
+ label = "buffalo:orange:security_n";
+ gpios = <&gpio0 13 1>;
+ };
+ };
+
+
+ pcibus0: pci@00440000 {
+ compatible = "ralink,rt288x-pci";
+ reg = <0x00440000 0x20000>;
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ status = "ok";
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 73637300fd..6e6b10bd46 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -395,6 +395,8 @@ Image/Build/Profile/V11STFE=$(call BuildFirmware/Default4M/$(1),$(1),v11st-fe,V1
Image/Build/Profile/WLITX4AG300N=$(call BuildFirmware/Default4M/$(1),$(1),wli-tx4-ag300n,WLI-TX4-AG300N)
+Image/Build/Profile/WZRAGL300NH=$(call BuildFirmware/Default4M/$(1),$(1),wzr-agl300nh,WZR-AGL300NH)
+
ifeq ($(SUBTARGET),rt288x)
define Image/Build/Profile/Default
$(call Image/Build/Profile/AR670W,$(1))
@@ -403,6 +405,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/RTN15,$(1))
$(call Image/Build/Profile/V11STFE,$(1))
$(call Image/Build/Profile/WLITX4AG300N,$(1))
+ $(call Image/Build/Profile/WZRAGL300NH,$(1))
endef
endif