summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-07-22 09:58:21 +0000
committerJohn Crispin <john@openwrt.org>2014-07-22 09:58:21 +0000
commit2c356c4bb7ab3e0090c8af440e3c6622c6be3fa3 (patch)
tree23e69135b5b70c487bcede3c4b8adcbd48a79027
parentb864faa47c02734936a689ff562a695f9dbeace4 (diff)
downloadmaster-31e0f0ae-2c356c4bb7ab3e0090c8af440e3c6622c6be3fa3.tar.gz
master-31e0f0ae-2c356c4bb7ab3e0090c8af440e3c6622c6be3fa3.tar.bz2
master-31e0f0ae-2c356c4bb7ab3e0090c8af440e3c6622c6be3fa3.zip
ramips: add a profile for AWM003
same as AWM002 but with 64mb RAM Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 41797
-rw-r--r--target/linux/ramips/dts/AWM003-EVB.dts59
-rw-r--r--target/linux/ramips/image/Makefile1
-rw-r--r--target/linux/ramips/rt305x/profiles/asiarf.mk13
3 files changed, 72 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/AWM003-EVB.dts b/target/linux/ramips/dts/AWM003-EVB.dts
new file mode 100644
index 0000000000..08157f5b2c
--- /dev/null
+++ b/target/linux/ramips/dts/AWM003-EVB.dts
@@ -0,0 +1,59 @@
+/dts-v1/;
+
+/include/ "AWM002-8M.dtsi"
+
+/ {
+ compatible = "AWM003", "ralink,rt5350-soc";
+ model = "AsiaRF AWM003 EVB";
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x4000000>;
+ };
+
+ palmbus@10000000 {
+ spi@b00 {
+ m25p80@0 {
+ compatible = "mx25l6405d";
+ linux,modalias = "m25p80", "mx25l6405d";
+ };
+ };
+ };
+
+ wmac@10180000 {
+ ralink,mtd-eeprom = <&factory 0>;
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ tx {
+ label = "awm002-evb:green:tx";
+ gpios = <&gpio0 15 1>;
+ };
+ rx {
+ label = "awm002-evb:green:rx";
+ gpios = <&gpio0 16 1>;
+ };
+ wps {
+ label = "awm002-evb:green:wps";
+ gpios = <&gpio0 21 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ reset_wps {
+ label = "reset_wps";
+ gpios = <&gpio0 0 1>;
+ linux,code = <0x198>;
+ };
+ mode {
+ label = "mode";
+ gpios = <&gpio0 21 1>;
+ linux,code = <0x32>;
+ };
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index c7225a6a39..ef019ef2f7 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -348,6 +348,7 @@ endef
Image/Build/Profile/ASL26555=$(call BuildFirmware/ASL26555/$(1),$(1),asl26555,ASL26555)
Image/Build/Profile/AWM002EVB=$(call BuildFirmware/DefaultDualSize/$(1),$(1),awm002-evb,AWM002-EVB)
+Image/Build/Profile/AWM003EVB=$(call BuildFirmware/Default8M/$(1),$(1),awm003-evb,AWM003-EVB)
Image/Build/Profile/AWAPN2403=$(call BuildFirmware/Default4M/$(1),$(1),awmapn2403,AWAPN2403)
Image/Build/Profile/BC2=$(call BuildFirmware/Default8M/$(1),$(1),bc2,BC2)
diff --git a/target/linux/ramips/rt305x/profiles/asiarf.mk b/target/linux/ramips/rt305x/profiles/asiarf.mk
index 8aef8a8e4b..a0bd38575d 100644
--- a/target/linux/ramips/rt305x/profiles/asiarf.mk
+++ b/target/linux/ramips/rt305x/profiles/asiarf.mk
@@ -8,13 +8,23 @@
define Profile/AWM002EVB
NAME:=AsiaRF AWM002-EVB
PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
- kmod-i2c-core kmod-i2c-gpio
+ kmod-i2c-core kmod-i2c-gpio
endef
define Profile/AWM002EVB/Description
Package set for AsiaRF AWM002 Evaluation Board
endef
+define Profile/AWM003EVB
+ NAME:=AsiaRF AWM003-EVB
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev \
+ kmod-i2c-core kmod-i2c-gpio
+endef
+
+define Profile/AWM003EVB/Description
+ Package set for AsiaRF AWM003 Evaluation Board
+endef
+
define Profile/AWAPN2403
NAME:=AsiaRF AWAPN2403
endef
@@ -24,4 +34,5 @@ define Profile/AWAPN2403/Description
endef
$(eval $(call Profile,AWM002EVB))
+$(eval $(call Profile,AWM003EVB))
$(eval $(call Profile,AWAPN2403))