summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-03-13 18:11:31 +0000
committerJohn Crispin <john@openwrt.org>2013-03-13 18:11:31 +0000
commit16b84af05e0447b67cfcc010a3f671985f788f14 (patch)
tree799894945d0b82fb43af6ee1123634c400506bbd
parentfce3deddff594be4a9d71f53e5ed6812033c2dd0 (diff)
downloadmaster-31e0f0ae-16b84af05e0447b67cfcc010a3f671985f788f14.tar.gz
master-31e0f0ae-16b84af05e0447b67cfcc010a3f671985f788f14.tar.bz2
master-31e0f0ae-16b84af05e0447b67cfcc010a3f671985f788f14.zip
make init and logread depend on !PROCD_INIT
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36005
-rw-r--r--package/busybox/Makefile2
-rw-r--r--package/busybox/config/init/Config.in1
-rw-r--r--package/busybox/config/sysklogd/Config.in2
3 files changed, 4 insertions, 1 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index 7aaaf6cb17..f4553c0ffe 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
+PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
PKG_BUILD_PARALLEL:=1
@@ -112,6 +113,7 @@ define Package/busybox/install
$(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
done
-rm -rf $(1)/lib64
+ $(if $(CONFIG_PROCD_INIT),rm -f $(1)/sbin/init $(1)/sbin/logread)
endef
$(eval $(call BuildPackage,busybox))
diff --git a/package/busybox/config/init/Config.in b/package/busybox/config/init/Config.in
index 61c20140b7..4b3c8dd160 100644
--- a/package/busybox/config/init/Config.in
+++ b/package/busybox/config/init/Config.in
@@ -73,6 +73,7 @@ config BUSYBOX_CONFIG_INIT
bool "init"
default y
select BUSYBOX_CONFIG_FEATURE_SYSLOG
+ depends on !PROCD_INIT
help
init is the first program run when the system boots.
diff --git a/package/busybox/config/sysklogd/Config.in b/package/busybox/config/sysklogd/Config.in
index 20e1aff063..087a5b4e50 100644
--- a/package/busybox/config/sysklogd/Config.in
+++ b/package/busybox/config/sysklogd/Config.in
@@ -96,7 +96,7 @@ config BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG_BUFFER_SIZE
config BUSYBOX_CONFIG_LOGREAD
bool "logread"
default y
- depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG
+ depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG && !PROCD_INIT
help
If you enabled Circular Buffer support, you almost
certainly want to enable this feature as well. This