summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2016-08-10 02:18:32 +0200
committerJohn Crispin <john@phrozen.org>2016-08-10 03:04:08 +0200
commit0f73801f4ff49cf9601e8f13c11f7d7928c1186b (patch)
treea7c1aa15dc818712252c3344db17fef90de4b704
parent5fadd4397b395e5760f3c86751b711688efca6e9 (diff)
downloadmaster-31e0f0ae-0f73801f4ff49cf9601e8f13c11f7d7928c1186b.tar.gz
master-31e0f0ae-0f73801f4ff49cf9601e8f13c11f7d7928c1186b.tar.bz2
master-31e0f0ae-0f73801f4ff49cf9601e8f13c11f7d7928c1186b.zip
ramips: Add support for Thunder Timecloud
Thunder Timecloud is a small NAS with MT7621A. It has 1 USB port and an SD Card slot. There is no wireless cards. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/Timecloud.dts110
-rw-r--r--target/linux/ramips/image/mt7621.mk7
6 files changed, 124 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 6aba1b0b1d..0bf1a8a3ba 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -49,6 +49,7 @@ ramips_setup_interfaces()
microwrt|\
mpr-a2|\
ncs601w|\
+ timecloud|\
w150m|\
widora-neo|\
wnce2001|\
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index da0cecd344..5693f6307e 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -118,7 +118,8 @@ get_status_led() {
f5d8235-v2)
status_led="$board:blue:router"
;;
- f7c027)
+ f7c027|\
+ timecloud)
status_led="$board:orange:status"
;;
hc5*61|\
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 1ea4fb2d71..1e9fa90b5d 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -406,6 +406,9 @@ ramips_board_detect() {
*"TEW-714TRU")
name="tew-714tru"
;;
+ *"Timecloud")
+ name="timecloud"
+ ;;
*"UBNT-ERX")
name="ubnt-erx"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index d9adf184d4..d7f5a73e77 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -119,6 +119,7 @@ platform_check_image() {
tew-691gr|\
tew-692gr|\
tew-714tru|\
+ timecloud|\
tiny-ac|\
ur-326n4g|\
ur-336un|\
diff --git a/target/linux/ramips/dts/Timecloud.dts b/target/linux/ramips/dts/Timecloud.dts
new file mode 100644
index 0000000000..8ee312cd86
--- /dev/null
+++ b/target/linux/ramips/dts/Timecloud.dts
@@ -0,0 +1,110 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+/ {
+ compatible = "mediatek,mt7621-eval-board", "mediatek,mt7621-soc";
+ model = "Thunder Timecloud";
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x10000000>;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ statw {
+ label = "timecloud:white:status";
+ gpios = <&gpio0 7 0>;
+ };
+
+ stato {
+ label = "timecloud:orange:status";
+ gpios = <&gpio0 8 0>;
+ };
+
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 13 1>;
+ linux,code = <0x198>;
+ };
+
+ BTN_0 {
+ label = "BTN_0";
+ gpios = <&gpio0 4 1>;
+ linux,code = <0x100>;
+ };
+ };
+};
+
+&sdhci {
+ status = "okay";
+ pinctrl-names = "default";
+ pinctrl-0 = <&sdhci_pins>;
+};
+
+&xhci {
+ status = "okay";
+};
+
+&spi0 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ linux,modalias = "m25p80";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0xe000>;
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "uart2", "jtag";
+ ralink,function = "gpio";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 59a9332294..e602dfb409 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -105,6 +105,13 @@ define Device/sap-g3200u3
endef
TARGET_DEVICES += sap-g3200u3
+define Device/timecloud
+ DTS := Timecloud
+ DEVICE_TITLE := Thunder Timecloud
+ DEVICE_PACKAGES := kmod-usb3
+endef
+TARGET_DEVICES += timecloud
+
define Device/witi
DTS := WITI
IMAGE_SIZE := $(ralink_default_fw_size_16M)