summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-07-10 22:02:28 +0000
committerJohn Crispin <john@openwrt.org>2014-07-10 22:02:28 +0000
commit03faf4618e65079268a7372a13669d5e10869c88 (patch)
tree746bde3f366ce5dc62a4de036d20c9af09971edb
parentf88fde968988a30b93dcba7f0e1aca171cd61da2 (diff)
downloadmaster-31e0f0ae-03faf4618e65079268a7372a13669d5e10869c88.tar.gz
master-31e0f0ae-03faf4618e65079268a7372a13669d5e10869c88.tar.bz2
master-31e0f0ae-03faf4618e65079268a7372a13669d5e10869c88.zip
ramips: add support for Zbtlink WA05 router
Signed-off-by: Roman Yeryomin <roman@advem.lv> SVN-Revision: 41579
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/01_leds5
-rwxr-xr-xtarget/linux/ramips/base-files/etc/uci-defaults/02_network3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh3
-rw-r--r--target/linux/ramips/dts/ZBT-WA05.dts112
-rw-r--r--target/linux/ramips/image/Makefile2
6 files changed, 126 insertions, 2 deletions
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/01_leds b/target/linux/ramips/base-files/etc/uci-defaults/01_leds
index c2f768b8a3..00b604008e 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/01_leds
+++ b/target/linux/ramips/base-files/etc/uci-defaults/01_leds
@@ -181,6 +181,11 @@ case $board in
ucidef_set_led_default "power" "power" "buffalo:green:power" "1"
ucidef_set_led_default "router" "router" "buffalo:green:router" "1"
;;
+ zbt-wa05)
+ ucidef_set_led_default "power" "power" "zbtlink:blue:power" "1"
+ set_wifi_led "zbtlink:blue:air"
+ set_usb_led "zbtlink:blue:usb"
+ ;;
esac
ucidef_commit_leds
diff --git a/target/linux/ramips/base-files/etc/uci-defaults/02_network b/target/linux/ramips/base-files/etc/uci-defaults/02_network
index 4eef735d93..a14acb6252 100755
--- a/target/linux/ramips/base-files/etc/uci-defaults/02_network
+++ b/target/linux/ramips/base-files/etc/uci-defaults/02_network
@@ -112,7 +112,8 @@ ramips_setup_interfaces()
hg255d | \
rt-n14u | \
wrtnode | \
- ur-326n4g)
+ ur-326n4g | \
+ zbt-wa05)
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
ucidef_add_switch "switch0" "1" "1"
ucidef_add_switch_vlan "switch0" "1" "1 2 3 4 6t"
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index ca339b354c..2ae8c9e8ff 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -307,6 +307,9 @@ ramips_board_detect() {
*"Sercomm NA930")
name="na930"
;;
+ *"Zbtlink ZBT-WA05")
+ name="zbt-wa05"
+ ;;
*)
name="generic"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index a39c433e8f..805a63fed4 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -91,7 +91,8 @@ platform_check_image() {
wmr300 |\
wrtnode |\
x5 |\
- x8)
+ x8 |\
+ zbt-wa05)
[ "$magic" != "27051956" ] && {
echo "Invalid image type."
return 1
diff --git a/target/linux/ramips/dts/ZBT-WA05.dts b/target/linux/ramips/dts/ZBT-WA05.dts
new file mode 100644
index 0000000000..714d2733a6
--- /dev/null
+++ b/target/linux/ramips/dts/ZBT-WA05.dts
@@ -0,0 +1,112 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+ compatible = "zbtlink,zbt-wa05", "ralink,mt7620n-soc";
+ model = "Zbtlink ZBT-WA05";
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ palmbus@10000000 {
+ gpio1: gpio@638 {
+ status = "okay";
+ };
+
+ gpio2: gpio@660 {
+ status = "okay";
+ };
+
+ gpio3: gpio@688 {
+ status = "okay";
+ };
+
+ spi@b00 {
+ status = "okay";
+
+ en25q64@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "w25q64";
+ reg = <0 0>;
+ linux,modalias = "m25p80";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x760000>;
+ };
+ };
+ };
+ };
+
+ ehci@101c0000 {
+ status = "okay";
+ };
+
+ ohci@101c1000 {
+ status = "okay";
+ };
+
+ ethernet@10100000 {
+ mtd-mac-address = <&factory 0x4>;
+ ralink,port-map = "llllw";
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ default {
+ ralink,group = "i2c", "spi refclk", "wled";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ power {
+ label = "zbtlink:blue:power";
+ gpios = <&gpio1 14 1>;
+ };
+ usb {
+ label = "zbtlink:blue:usb";
+ gpios = <&gpio1 15 0>;
+ };
+ air {
+ label = "zbtlink:blue:air";
+ gpios = <&gpio3 0 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ reset {
+ label = "reset";
+ gpios = <&gpio0 1 1>;
+ linux,code = <0x198>;
+ };
+ };
+};
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 5b23035b4e..e3ba60ed95 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -738,12 +738,14 @@ endif
Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
Image/Build/Profile/WRTNODE=$(call BuildFirmware/Default16M/$(1),$(1),wrtnode,WRTNODE)
+Image/Build/Profile/ZBT-WA05=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wa05,ZBT-WA05)
ifeq ($(SUBTARGET),mt7620n)
define Image/Build/Profile/Default
$(call Image/Build/Profile/WMR300,$(1))
$(call Image/Build/Profile/RT-N14U,$(1))
$(call Image/Build/Profile/WRTNODE,$(1))
+ $(call Image/Build/Profile/ZBT-WA05,$(1))
endef
endif