summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-03-07 13:07:17 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-03-07 13:07:17 +0000
commit02dee9126e5201fc1c326a65b3e8aeb114d0cb14 (patch)
tree91b0ad4dffbebe7449a1a1c7625bc6d852ab5236
parentb74308c4337b9309f2eb86ca54e6c10edebddc13 (diff)
downloadmaster-31e0f0ae-02dee9126e5201fc1c326a65b3e8aeb114d0cb14.tar.gz
master-31e0f0ae-02dee9126e5201fc1c326a65b3e8aeb114d0cb14.tar.bz2
master-31e0f0ae-02dee9126e5201fc1c326a65b3e8aeb114d0cb14.zip
use the xscale hal by default for arm, override it where needed
SVN-Revision: 25929
-rw-r--r--package/madwifi/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 6350a18052..bd0792a4b6 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -73,27 +73,24 @@ endif
ifeq ($(ARCH),i686)
HAL_TARGET:=i386-elf
endif
-ifeq ($(BOARD),ixp4xx)
+ifeq ($(ARCH),armeb)
HAL_TARGET:=xscale-be-elfgnueabi
endif
-ifeq ($(BOARD),iop32x)
+ifneq ($(ARCH),arm)
HAL_TARGET:=xscale-le-elfgnueabi
-endif
-ifeq ($(BOARD),kirkwood)
- HAL_TARGET:=xscale-le-elfgnueabi
-endif
-ifeq ($(BOARD),orion)
- HAL_TARGET:=xscale-le-elfgnueabi
-endif
-ifeq ($(BOARD),cns3xxx)
- HAL_TARGET:=arm11-le-elfgnueabi
+ ifeq ($(BOARD),cns21xx)
+ HAL_TARGET:=armv4-le-elfgnueabi
+ endif
+ ifeq ($(BOARD),cns3xxx)
+ HAL_TARGET:=arm11-le-elfgnueabi
+ endif
+ ifeq ($(BOARD),gemini)
+ HAL_TARGET:=armv4-le-elfgnueabi
+ endif
endif
ifeq ($(ARCH),powerpc)
HAL_TARGET:=powerpc-be-elf
endif
-ifeq ($(BOARD),gemini)
- HAL_TARGET:=armv4-le-elfgnueabi
-endif
ifneq ($(CONFIG_TARGET_atheros),)
HAL_TARGET:=wisoc
endif