summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-08 22:21:23 +0200
committerMathias Kresin <dev@kresin.me>2016-09-08 22:21:23 +0200
commitfb39b77ccb6b64d58ee63aa53cfaa57a49e64be6 (patch)
treeb6a6469e7a5845aab3c8fd4cf6e0bb6e9f8f4d9a
parentbd39104e95fc5f0102e06e48f5ab97ed36bd56d3 (diff)
downloadmaster-31e0f0ae-fb39b77ccb6b64d58ee63aa53cfaa57a49e64be6.tar.gz
master-31e0f0ae-fb39b77ccb6b64d58ee63aa53cfaa57a49e64be6.tar.bz2
master-31e0f0ae-fb39b77ccb6b64d58ee63aa53cfaa57a49e64be6.zip
ramips: switch DIR-610 A1 to new image build code
Signed-off-by: Mathias Kresin <dev@kresin.me>
-rw-r--r--target/linux/ramips/image/rt305x-legacy.mk20
1 files changed, 17 insertions, 3 deletions
diff --git a/target/linux/ramips/image/rt305x-legacy.mk b/target/linux/ramips/image/rt305x-legacy.mk
index 44c436b9e0..a6ae06081a 100644
--- a/target/linux/ramips/image/rt305x-legacy.mk
+++ b/target/linux/ramips/image/rt305x-legacy.mk
@@ -157,7 +157,6 @@ define Image/Build/Profile/ALL02393G
$(call Image/Build/Template/$(image_type)/$(1),UIMAGE_8M,all0239-3g,ALL0239-3G,ttyS1,57600,phys)
endef
-Image/Build/Profile/DIR610A1=$(call BuildFirmware/Seama/$(1),$(1),dir-610-a1,DIR-610-A1,wrgn59_dlob.hans_dir610,$(ralink_default_fw_size_4M))
edimax_3g6200n_mtd_size=3735552
Image/Build/Profile/3G6200N=$(call BuildFirmware/Edimax/$(1),$(1),3g-6200n,3G-6200N,$(edimax_3g6200n_mtd_size),CSYS,3G62,0x50000,0xc0000)
Image/Build/Profile/3G6200NL=$(call BuildFirmware/Edimax/$(1),$(1),3g-6200nl,3G-6200NL,$(edimax_3g6200n_mtd_size),CSYS,3G62,0x50000,0xc0000)
@@ -203,11 +202,26 @@ endef
LEGACY_DEVICES += ALL02393G
-define LegacyDevice/DIR610A1
+define Device/dir-610-a1
+ DTS := DIR-610-A1
+ BLOCKSIZE := 4k
+ IMAGES += factory.bin
+ KERNEL := $(KERNEL_DTB)
+ IMAGE_SIZE := $(ralink_default_fw_size_4M)
+ IMAGE/sysupgrade.bin := \
+ append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs | \
+ seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
+ pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ IMAGE/factory.bin := \
+ append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
+ append-rootfs | pad-rootfs -x 64 | \
+ seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
+ seama-seal -m "signature=wrgn59_dlob.hans_dir610" | \
+ check-size $$$$(IMAGE_SIZE)
DEVICE_TITLE := D-Link DIR-610 A1
DEVICE_PACKAGES := kmod-ledtrig-netdev kmod-ledtrig-timer
endef
-LEGACY_DEVICES += DIR610A1
+TARGET_DEVICES += dir-610-a1
define LegacyDevice/3G6200N