summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-15 20:35:58 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-15 20:55:40 +0200
commitf4c4d501e4edc579e74e720b0a9e3f22532b0dab (patch)
treef1d577da805a97b0730be1b2c0e8ff85cb39b59b
parent7a67b0e362fdefd02a914a350b77da1e535f315e (diff)
downloadmaster-31e0f0ae-f4c4d501e4edc579e74e720b0a9e3f22532b0dab.tar.gz
master-31e0f0ae-f4c4d501e4edc579e74e720b0a9e3f22532b0dab.tar.bz2
master-31e0f0ae-f4c4d501e4edc579e74e720b0a9e3f22532b0dab.zip
build: remove profile kernel/build system config override support
It has been unused for years Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--include/target.mk7
-rwxr-xr-xscripts/metadata.pl2
-rw-r--r--scripts/metadata.pm2
-rw-r--r--target/Config.in3
-rw-r--r--target/imagebuilder/Config.in1
5 files changed, 0 insertions, 15 deletions
diff --git a/include/target.mk b/include/target.mk
index 0666df63a1..92edaec96b 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -67,19 +67,12 @@ ifndef Profile
define Profile
$(eval $(call ProfileDefault))
$(eval $(call Profile/$(1)))
- dumpinfo : $(call shexport,Profile/$(1)/Config)
dumpinfo : $(call shexport,Profile/$(1)/Description)
DUMPINFO += \
echo "Target-Profile: $(1)"; \
$(if $(PRIORITY), echo "Target-Profile-Priority: $(PRIORITY)"; ) \
echo "Target-Profile-Name: $(NAME)"; \
echo "Target-Profile-Packages: $(PACKAGES) $(call extra_packages,$(DEFAULT_PACKAGES) $(PACKAGES))"; \
- if [ -f ./config/profile-$(1) ]; then \
- echo "Target-Profile-Kconfig: yes"; \
- fi; \
- echo "Target-Profile-Config: "; \
- echo "$$$$$$$$$(call shvar,Profile/$(1)/Config)"; \
- echo "@@"; \
echo "Target-Profile-Description:"; \
echo "$$$$$$$$$(call shvar,Profile/$(1)/Description)"; \
echo "@@"; \
diff --git a/scripts/metadata.pl b/scripts/metadata.pl
index c7582b42dc..822382cd6c 100755
--- a/scripts/metadata.pl
+++ b/scripts/metadata.pl
@@ -287,9 +287,7 @@ EOF
config TARGET_$target->{conf}_$profile->{id}
bool "$profile->{name}"
depends on TARGET_$target->{conf}
-$profile->{config}
EOF
- $profile->{kconfig} and print "\tselect PROFILE_KCONFIG\n";
my @pkglist = merge_package_lists($target->{packages}, $profile->{packages});
foreach my $pkg (@pkglist) {
print "\tselect DEFAULT_$pkg\n";
diff --git a/scripts/metadata.pm b/scripts/metadata.pm
index e2a739533c..b3f34f79e9 100644
--- a/scripts/metadata.pm
+++ b/scripts/metadata.pm
@@ -96,8 +96,6 @@ sub parse_target_metadata($) {
};
/^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
/^Target-Profile-Description:\s*(.*)\s*/ and $profile->{desc} = get_multiline(*FILE);
- /^Target-Profile-Config:/ and $profile->{config} = get_multiline(*FILE, "\t");
- /^Target-Profile-Kconfig:/ and $profile->{kconfig} = 1;
}
close FILE;
foreach my $target (@target) {
diff --git a/target/Config.in b/target/Config.in
index 571b06ebcf..3dc8655252 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -67,9 +67,6 @@ config USES_UBIFS
bool
select NAND_SUPPORT
-config PROFILE_KCONFIG
- bool
-
config LOW_MEMORY_FOOTPRINT
bool
diff --git a/target/imagebuilder/Config.in b/target/imagebuilder/Config.in
index 245c71583d..b54eb5b4ff 100644
--- a/target/imagebuilder/Config.in
+++ b/target/imagebuilder/Config.in
@@ -1,6 +1,5 @@
config IB
bool "Build the LEDE Image Builder"
- depends on !PROFILE_KCONFIG
depends on !EXTERNAL_TOOLCHAIN
help
This is essentially a stripped-down version of the buildroot