summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2016-09-23 17:39:47 -0500
committerJohn Crispin <john@phrozen.org>2016-09-27 17:50:21 +0200
commitedbc8fec8a9747a746fc321e97d9b96f7e95fa7e (patch)
treeff69a285bfbb42f422fa84d13a50beb3521d87bb
parent509708889ca28643cf0d7d9c75a2a72ef386e4e1 (diff)
downloadmaster-31e0f0ae-edbc8fec8a9747a746fc321e97d9b96f7e95fa7e.tar.gz
master-31e0f0ae-edbc8fec8a9747a746fc321e97d9b96f7e95fa7e.tar.bz2
master-31e0f0ae-edbc8fec8a9747a746fc321e97d9b96f7e95fa7e.zip
libjson-c: Update to 0.12.1
Updates libjson-c and removes backport patch. Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
-rw-r--r--package/libs/libjson-c/Makefile8
-rw-r--r--package/libs/libjson-c/patches/001-backport_compile_fix.patch23
2 files changed, 5 insertions, 26 deletions
diff --git a/package/libs/libjson-c/Makefile b/package/libs/libjson-c/Makefile
index 404a55d417..51cc645045 100644
--- a/package/libs/libjson-c/Makefile
+++ b/package/libs/libjson-c/Makefile
@@ -8,12 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=json-c
-PKG_VERSION:=0.12
+PKG_VERSION:=0.12.1
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nodoc.tar.gz
PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
-PKG_MD5SUM:=3ca4bbb881dfc4017e8021b5e0a8c491
+PKG_MD5SUM:=5b91ab230d9b6b0ee20fc19cf25094f5
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
diff --git a/package/libs/libjson-c/patches/001-backport_compile_fix.patch b/package/libs/libjson-c/patches/001-backport_compile_fix.patch
deleted file mode 100644
index e83f5d28a3..0000000000
--- a/package/libs/libjson-c/patches/001-backport_compile_fix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-commit 3859e99f50abe11a8dade28efa9ea3d99dfaac11
-Author: Petar Koretić <petar.koretic@gmail.com>
-Date: Fri Apr 11 10:03:40 2014 +0200
-
- Remove unused variable 'size'
-
-diff --git a/json_tokener.c b/json_tokener.c
-index 19de8ef..9a76293 100644
---- a/json_tokener.c
-+++ b/json_tokener.c
-@@ -352,12 +352,10 @@ struct json_object* json_tokener_parse_ex(struct json_tokener *tok,
-
- case json_tokener_state_inf: /* aka starts with 'i' */
- {
-- int size;
- int size_inf;
- int is_negative = 0;
-
- printbuf_memappend_fast(tok->pb, &c, 1);
-- size = json_min(tok->st_pos+1, json_null_str_len);
- size_inf = json_min(tok->st_pos+1, json_inf_str_len);
- char *infbuf = tok->pb->buf;
- if (*infbuf == '-')