summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-14 19:11:19 +0200
committerMathias Kresin <dev@kresin.me>2016-09-15 09:53:37 +0200
commiteb88a9cacb41a69cdeb335298882b218361ff825 (patch)
tree0b7e9f8b5d306fc4c830e25560746945dcd1dde0
parentd14c28fc80d98cc712074c869cbd1659398e8829 (diff)
downloadmaster-31e0f0ae-eb88a9cacb41a69cdeb335298882b218361ff825.tar.gz
master-31e0f0ae-eb88a9cacb41a69cdeb335298882b218361ff825.tar.bz2
master-31e0f0ae-eb88a9cacb41a69cdeb335298882b218361ff825.zip
ramips: fix wrong blocksizes
The D-Link DIR-860L B1 has a flash chip which doesn't support 4K sectors. Since the DIR-860L B1 was the only mt7621 board which had the 4k blocksize set, the 4K sector support is removed from the kernel config. I've checked the flash chips of all boards having set a 4K blocksize again. This time I searched harder to finding bootlogs instead of relying on wikis articles and/or the device tree source file. The Planex MZK-DP150N has an en25q32b instead of the mentioned one in the dts. Albeit the en25q32b supports 4K sectors, 4K support is not enabled in the driver. Change the blocksize for this board back to 64K. Reported-by: Russell Senior <russell@personaltelco.net> Signed-off-by: Mathias Kresin <dev@kresin.me>
-rw-r--r--target/linux/ramips/image/mt7621.mk2
-rw-r--r--target/linux/ramips/image/rt305x.mk2
-rw-r--r--target/linux/ramips/mt7621/config-4.41
3 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index ceed8ab4f1..0c14d515d0 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -57,7 +57,7 @@ TARGET_DEVICES += wsr-1166
define Device/dir-860l-b1
DTS := DIR-860L-B1
- BLOCKSIZE := 4k
+ BLOCKSIZE := 64k
IMAGES += factory.bin
KERNEL := kernel-bin | patch-dtb | relocate-kernel | lzma | uImage lzma
IMAGE_SIZE := $(ralink_default_fw_size_16M)
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 13193ae796..be21ac47b9 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -432,7 +432,7 @@ TARGET_DEVICES += wcr150gn
define Device/mzk-dp150n
DTS := MZK-DP150N
- BLOCKSIZE := 4k
+ BLOCKSIZE := 64k
IMAGE_SIZE := $(ralink_default_fw_size_4M)
DEVICE_TITLE := Planex MZK-DP150N
DEVICE_PACKAGES := kmod-spi-dev
diff --git a/target/linux/ramips/mt7621/config-4.4 b/target/linux/ramips/mt7621/config-4.4
index b391005a31..9132d894df 100644
--- a/target/linux/ramips/mt7621/config-4.4
+++ b/target/linux/ramips/mt7621/config-4.4
@@ -159,7 +159,6 @@ CONFIG_MTD_NAND=y
CONFIG_MTD_NAND_ECC=y
CONFIG_MTD_PHYSMAP=y
CONFIG_MTD_SPI_NOR=y
-CONFIG_MTD_SPI_NOR_USE_4K_SECTORS=y
CONFIG_MTD_SPLIT_FIRMWARE=y
CONFIG_MTD_SPLIT_SEAMA_FW=y
CONFIG_MTD_SPLIT_TRX_FW=y