summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-20 16:17:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-20 16:17:50 +0000
commite554dafa937397d8a0c5894effa1d1c8dc7868d7 (patch)
treeeb8eee69f9095e59a562a6a44a4a30314ae07e47
parentc538ef98994a73603e98fa77ad86fb4e55f906d9 (diff)
downloadmaster-31e0f0ae-e554dafa937397d8a0c5894effa1d1c8dc7868d7.tar.gz
master-31e0f0ae-e554dafa937397d8a0c5894effa1d1c8dc7868d7.tar.bz2
master-31e0f0ae-e554dafa937397d8a0c5894effa1d1c8dc7868d7.zip
fix spontaneous rebuilds caused by make package/<name>/update with quilt
SVN-Revision: 8879
-rw-r--r--include/host-build.mk2
-rw-r--r--include/package.mk2
-rw-r--r--include/quilt.mk1
3 files changed, 2 insertions, 3 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 581c2cfd4e..88129aad07 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
-STAMP_PREPARED:=$(PKG_BUILD_DIR)/.prepared_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),))
+STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.$(PKG_NAME)_installed
diff --git a/include/package.mk b/include/package.mk
index 591816b755..43d0663f60 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -16,7 +16,7 @@ include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
-STAMP_PREPARED:=$(PKG_BUILD_DIR)/.prepared$(if $(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
+STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
diff --git a/include/quilt.mk b/include/quilt.mk
index a2cbdf9eeb..a7aac91c06 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -26,7 +26,6 @@ endef
QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
ifneq ($(QUILT),)
- STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
override CONFIG_AUTOREBUILD=
define Build/Patch/Default