summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2016-09-23 13:53:27 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2016-09-26 12:48:18 +0200
commitd8075b15d09acdd02cd874f8969eeab0ecbe3f23 (patch)
tree29c3b87b9db2bbf86fd422b45b4d0230cc00760f
parentbc1f006b4eea84d9f3fb2e9b9c5571557042f697 (diff)
downloadmaster-31e0f0ae-d8075b15d09acdd02cd874f8969eeab0ecbe3f23.tar.gz
master-31e0f0ae-d8075b15d09acdd02cd874f8969eeab0ecbe3f23.tar.bz2
master-31e0f0ae-d8075b15d09acdd02cd874f8969eeab0ecbe3f23.zip
uboot-mvebu: make hidden and be m for clearfog to fix IB failing to add it
Uboot-mvebu isn't a real package, which will break the image builder when it tries to install it during the packing step. Instead of cleafog selecting it through its default packages, make it default to m if the clearfog profile is selected. This will ensure it is always build, but never added to the rootfs. This fixes creating images for clearfog with IB. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com> Acked-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--package/boot/uboot-mvebu/Makefile8
-rw-r--r--target/linux/mvebu/image/Makefile2
2 files changed, 6 insertions, 4 deletions
diff --git a/package/boot/uboot-mvebu/Makefile b/package/boot/uboot-mvebu/Makefile
index 3cf6358448..2d01f86fcb 100644
--- a/package/boot/uboot-mvebu/Makefile
+++ b/package/boot/uboot-mvebu/Makefile
@@ -21,7 +21,6 @@ PKG_MD5SUM:=973c1d896be751321cc3aafa564f64b2
PKG_LICENSE:=GPL-2.0 GPL-2.0+
PKG_LICENSE_FILES:=Licenses/README
-PKG_TARGETS:=bin
PKG_BUILD_PARALLEL:=1
@@ -33,6 +32,7 @@ endef
define uboot/clearfog
TITLE:=U-Boot for SolidRun ClearFog A1
+ DEVICE:=armada-388-clearfog
endef
UBOOTS:= \
@@ -42,7 +42,9 @@ define Package/uboot/template
define Package/uboot-mvebu-$(1)
SECTION:=boot
CATEGORY:=Boot Loaders
- DEPENDS:=@TARGET_mvebu
+ DEPENDS:=@(TARGET_DEVICE_mvebu_DEVICE_$(3)||TARGET_mvebu_DEVICE_$(3))
+ DEFAULT:=m
+ HIDDEN:=1
TITLE:=$(2)
URL:=http://www.denx.de/wiki/U-Boot
VARIANT:=$(1)
@@ -53,7 +55,7 @@ endef
define BuildUBootPackage
$(eval $(uboot/Default))
$(eval $(uboot/$(1)))
- $(call Package/uboot/template,$(1),$(TITLE))
+ $(call Package/uboot/template,$(1),$(TITLE),$(DEVICE))
endef
define Build/Configure
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index cf9d3c0ba2..7d58ed7df4 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -175,7 +175,7 @@ define Device/armada-388-clearfog
KERNEL_INSTALL := 1
KERNEL := dtb | kernel-bin
DEVICE_TITLE := SolidRun ClearFog
- DEVICE_PACKAGES := uboot-mvebu-clearfog mkf2fs e2fsprogs
+ DEVICE_PACKAGES := mkf2fs e2fsprogs
IMAGES := bundle.tar.gz sdcard.img.gz
IMAGE/bundle.tar.gz := clearfog-bundle
IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip