summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-09-12 18:20:50 +0200
committerFelix Fietkau <nbd@nbd.name>2016-09-12 18:21:52 +0200
commitd27bce8d28eb129af0abd9c80a7756301b7d588a (patch)
tree8abfae3b1d00dd60a78ab0453ea026ea371974b4
parentf3747020e202883a43729fc245986f9e36289d6c (diff)
downloadmaster-31e0f0ae-d27bce8d28eb129af0abd9c80a7756301b7d588a.tar.gz
master-31e0f0ae-d27bce8d28eb129af0abd9c80a7756301b7d588a.tar.bz2
master-31e0f0ae-d27bce8d28eb129af0abd9c80a7756301b7d588a.zip
build: drop UBI EOF marker from images by default
Only add them where they are actually required. Should help with compatibility issues with stock U-Boot images that access UBI Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--include/image.mk2
-rw-r--r--target/linux/bcm53xx/image/Makefile1
-rw-r--r--target/linux/imx6/image/Makefile1
-rw-r--r--target/linux/kirkwood/image/Makefile1
-rw-r--r--target/linux/mvebu/image/Makefile1
-rw-r--r--target/linux/ramips/image/mt7621.mk1
6 files changed, 4 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index bab7f533a2..8cc6e38cad 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -353,7 +353,7 @@ define Device/Init
PAGESIZE :=
SUBPAGESIZE :=
VID_HDR_OFFSET :=
- UBINIZE_OPTS := -E 5
+ UBINIZE_OPTS :=
UBINIZE_PARTS :=
MKUBIFS_OPTS :=
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 2f45a7b440..e2665acefa 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -85,7 +85,6 @@ define Device/Default
IMAGES := trx
BLOCKSIZE := 128k
PAGESIZE := 2048
- UBINIZE_OPTS :=
IMAGE/trx := append-ubi | trx-nand
endef
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 86e3308c79..3ff1d363d9 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -94,7 +94,6 @@ define Device/ventana
kobs-ng
KERNEL += | boot-overlay
IMAGES := nand.ubi bootfs.tar.gz
- UBINIZE_OPTS :=
UBINIZE_PARTS = boot=$$(KDIR_KERNEL_IMAGE).boot.ubifs=15
IMAGE/nand.ubi := append-ubi
IMAGE/bootfs.tar.gz := bootfs.tar.gz | install-dtb
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 33eaa4f4b2..03a9873c9f 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -28,6 +28,7 @@ define Device/Default
SUBPAGESIZE := 512
BLOCKSIZE := 128k
IMAGES := sysupgrade.tar
+ UBINIZE_OPTS := -E 5
IMAGE/sysupgrade.tar := sysupgrade-tar
endef
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 7900fb9ddb..c855cca42c 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -71,6 +71,7 @@ endef
define Device/UBI-factory
$(Device/UBI)
+ UBINIZE_OPTS := -E 5
IMAGES += factory.img
IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
endef
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 769b86b81b..ceed8ab4f1 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -146,6 +146,7 @@ define Device/wf-2881
FILESYSTEMS := squashfs
IMAGE_SIZE := 129280k
KERNEL := $(KERNEL_DTB) | pad-offset $$(BLOCKSIZE) 64 | uImage lzma
+ UBINIZE_OPTS := -E 5
IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
DEVICE_TITLE := NETIS WF-2881
DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev