summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-14 02:28:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-14 02:28:34 +0000
commitaf03fdb6c5d9f94ec372cc9764a17b7d43a8edb0 (patch)
tree878cfa27441a631cb094b865c7cf85d93a534f02
parent1a3c4d109008e36e8d158670cf461f131d13f75e (diff)
downloadmaster-31e0f0ae-af03fdb6c5d9f94ec372cc9764a17b7d43a8edb0.tar.gz
master-31e0f0ae-af03fdb6c5d9f94ec372cc9764a17b7d43a8edb0.tar.bz2
master-31e0f0ae-af03fdb6c5d9f94ec372cc9764a17b7d43a8edb0.zip
add autorebuild check for menuconfig
SVN-Revision: 9301
-rw-r--r--Makefile1
-rw-r--r--include/depends.mk2
-rw-r--r--include/toplevel.mk2
3 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index dcd5bae72e..b67413b887 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,7 @@ ifneq ($(OPENWRT_BUILD),1)
override OPENWRT_BUILD=1
export OPENWRT_BUILD
include $(TOPDIR)/include/debug.mk
+ include $(TOPDIR)/include/depends.mk
include $(TOPDIR)/include/toplevel.mk
else
include rules.mk
diff --git a/include/depends.mk b/include/depends.mk
index b488af9271..4c31eb3984 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -28,7 +28,7 @@ define rdep
) \
{ \
[ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
- $(SCRIPT_DIR)/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
+ $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
$(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
touch -r "$(2)" "$(2)_check"; \
} \
diff --git a/include/toplevel.mk b/include/toplevel.mk
index dcbcb3eb75..c92686019d 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -52,7 +52,7 @@ prepare-tmpinfo: FORCE
scripts/config/mconf:
@+$(MAKE) -C scripts/config all
-$(call rdep,scripts/config,scripts/config/mconf)
+$(eval $(call rdep,scripts/config,scripts/config/mconf))
scripts/config/conf:
@+$(MAKE) -C scripts/config conf