summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2016-09-26 12:56:14 -0700
committerJohn Crispin <john@phrozen.org>2016-09-27 17:50:22 +0200
commitaaa067ab0b3cfd6d26f976e2e5e43ac15a8f0ee6 (patch)
treea87d9a0240bafba50e98da82a45e3e48ed0d7a0f
parent78ae7d8efda344075c7991c731afdbd47ae1cee9 (diff)
downloadmaster-31e0f0ae-aaa067ab0b3cfd6d26f976e2e5e43ac15a8f0ee6.tar.gz
master-31e0f0ae-aaa067ab0b3cfd6d26f976e2e5e43ac15a8f0ee6.tar.bz2
master-31e0f0ae-aaa067ab0b3cfd6d26f976e2e5e43ac15a8f0ee6.zip
openssl: Remove J-PAKE. Nothing uses it.
Signed-off by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--package/libs/openssl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index dc1202cd84..0df6f3edb6 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -16,6 +16,7 @@ PKG_USE_MIPS16:=0
PKG_BUILD_PARALLEL:=0
+
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -97,7 +98,7 @@ endef
OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-camellia no-krb5 \
- no-whrlpool no-whirlpool no-seed
+ no-whrlpool no-whirlpool no-seed no-jpake
OPENSSL_OPTIONS:= shared no-err no-sse2 no-ssl2 no-ssl2-method no-heartbeats
ifdef CONFIG_OPENSSL_ENGINE_CRYPTO