summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-12 01:49:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-12 01:49:35 +0000
commit8838ffd68d915fc356836468e30e7a26f1f6150a (patch)
treedc33a33b9c088333cd4e5ebc3dd1b11b3b7d09bc
parent0f4a0fa10aba839906dd7018fef5a1136a869157 (diff)
downloadmaster-31e0f0ae-8838ffd68d915fc356836468e30e7a26f1f6150a.tar.gz
master-31e0f0ae-8838ffd68d915fc356836468e30e7a26f1f6150a.tar.bz2
master-31e0f0ae-8838ffd68d915fc356836468e30e7a26f1f6150a.zip
speed up the build system a little bit
SVN-Revision: 5506
-rw-r--r--include/host.mk1
-rw-r--r--rules.mk1
2 files changed, 1 insertions, 1 deletions
diff --git a/include/host.mk b/include/host.mk
index ed961e35d9..1130d5b9a6 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -11,6 +11,7 @@ export TAR
$(TMP_DIR)/.host.mk: $(INCLUDE_DIR)/host.mk
@( \
+ echo -n "BASH:=$(shell which bash)"; \
HOST_OS=`uname`; \
case "$$HOST_OS" in \
Linux) HOST_ARCH=`uname -m`;; \
diff --git a/rules.mk b/rules.mk
index da0e04c1c4..d52539f3f2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -9,7 +9,6 @@
include $(TOPDIR)/include/verbose.mk
export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
-export BASH=$(shell which bash)
ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))