summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-09-27 16:20:57 +0200
committerJo-Philipp Wich <jo@mein.io>2016-09-27 16:23:06 +0200
commit864b2d113ad0815c2444575014e7cf51498944db (patch)
tree1a50ae61bb1ba471468f9d3820dad4d6f5ec1e38
parent45b73af7f6020b1c3e3d7170d3b1ba86edabfc60 (diff)
downloadmaster-31e0f0ae-864b2d113ad0815c2444575014e7cf51498944db.tar.gz
master-31e0f0ae-864b2d113ad0815c2444575014e7cf51498944db.tar.bz2
master-31e0f0ae-864b2d113ad0815c2444575014e7cf51498944db.zip
6in4: fix invalid local variable declaration (FS#188)
Remove an invalid local variable declaration in the tunnel update subshell invocation. Local declarations outside of function scopes are illegal since the Busybox update to version 1.25.0 . Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--package/network/ipv6/6in4/Makefile4
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index 5d9355fa54..34227ce9ef 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=23
+PKG_VERSION:=24
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
@@ -19,7 +19,7 @@ define Package/6in4
CATEGORY:=Network
DEPENDS:=@IPV6 +kmod-sit +uclient-fetch
TITLE:=IPv6-in-IPv4 configuration support
- MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+ MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
PKGARCH:=all
endef
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index c358a222fa..45d8ab75ad 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -11,7 +11,7 @@
proto_6in4_update() {
sh -c '
- local timeout=5
+ timeout=5
(while [ $((timeout--)) -gt 0 ]; do
sleep 1