summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-09-28 02:36:56 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-09-28 02:39:18 +0200
commit82aa061251f9efa68bea8fd4f3bcfb28d3654d5a (patch)
treeb33470a8585a67b5fc9a5ad1a9bdc9a3865d4b45
parenta0ce6982d883a5fd222ef8e26aa60e12f198d439 (diff)
downloadmaster-31e0f0ae-82aa061251f9efa68bea8fd4f3bcfb28d3654d5a.tar.gz
master-31e0f0ae-82aa061251f9efa68bea8fd4f3bcfb28d3654d5a.tar.bz2
master-31e0f0ae-82aa061251f9efa68bea8fd4f3bcfb28d3654d5a.zip
kernel: remove echainiv.ko from kmod-crypto-iv
There is a separate package kmod-crypto-echainiv for echainiv.ko. Selecting both packages led to a conflict, so remove the file from kmod-crypto-iv. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
-rw-r--r--package/kernel/linux/modules/crypto.mk7
1 files changed, 3 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index bea05488ab..0a88c3be12 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -123,12 +123,11 @@ $(eval $(call KernelPackage,crypto-rng))
define KernelPackage/crypto-iv
TITLE:=CryptoAPI initialization vectors
DEPENDS:=+kmod-crypto-manager +kmod-crypto-rng +kmod-crypto-wq
- KCONFIG:= CONFIG_CRYPTO_BLKCIPHER2 CONFIG_CRYPTO_ECHAINIV
+ KCONFIG:= CONFIG_CRYPTO_BLKCIPHER2
FILES:= \
$(LINUX_DIR)/crypto/eseqiv.ko \
- $(LINUX_DIR)/crypto/chainiv.ko \
- $(LINUX_DIR)/crypto/echainiv.ko@ge4.3
- AUTOLOAD:=$(call AutoLoad,10,eseqiv chainiv echainiv@ge4.3)
+ $(LINUX_DIR)/crypto/chainiv.ko
+ AUTOLOAD:=$(call AutoLoad,10,eseqiv chainiv)
$(call AddDepends/crypto)
endef