summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-07-31 22:32:21 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-07-31 22:32:21 +0000
commit7fc192e9a5d517f48561243d24a5e0a88cdd0805 (patch)
tree2cc03c881207bd49048e91d6c87f4dab5f7c52bb
parent5b365822f3249c4b7f0304ee5c9f526e1ba1c695 (diff)
downloadmaster-31e0f0ae-7fc192e9a5d517f48561243d24a5e0a88cdd0805.tar.gz
master-31e0f0ae-7fc192e9a5d517f48561243d24a5e0a88cdd0805.tar.bz2
master-31e0f0ae-7fc192e9a5d517f48561243d24a5e0a88cdd0805.zip
fix for GREP_OPTIONS
When using GREP_OPTIONS to supply default options to grep, the buildsystem might get broken (For example adding --color=always breaks it) This patch will empty the GREP_OPTIONS to prevent the described (and any other) problems related to GREP_OPTIONS Signed-off-by: Maarten Bezemer <m.m.bezemer@utwente.nl> SVN-Revision: 22443
-rw-r--r--Makefile2
-rw-r--r--rules.mk3
2 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index db79274c9a..31042b2e09 100644
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,8 @@ ifneq ($(OPENWRT_BUILD),1)
override OPENWRT_BUILD=1
export OPENWRT_BUILD
+ GREP_OPTIONS=
+ export GREP_OPTIONS
include $(TOPDIR)/include/debug.mk
include $(TOPDIR)/include/depends.mk
include $(TOPDIR)/include/toplevel.mk
diff --git a/rules.mk b/rules.mk
index 0cb72ac6bc..2add087133 100644
--- a/rules.mk
+++ b/rules.mk
@@ -18,6 +18,9 @@ TMP_DIR:=$(TOPDIR)/tmp
export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
+GREP_OPTIONS=
+export GREP_OPTIONS
+
qstrip=$(strip $(subst ",,$(1)))
#"))