summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-09-26 15:25:37 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-09-26 17:57:56 +0200
commit77f54eae453db4220547c4c17d29ff91351b06e0 (patch)
treeddb5f3b1057b80be84f1ad6c09bc143cb3191c25
parentda4e81960d64ddfcec03961520de4197166d0799 (diff)
downloadmaster-31e0f0ae-77f54eae453db4220547c4c17d29ff91351b06e0.tar.gz
master-31e0f0ae-77f54eae453db4220547c4c17d29ff91351b06e0.tar.bz2
master-31e0f0ae-77f54eae453db4220547c4c17d29ff91351b06e0.zip
config: enable shadow passwords unconditionally
Configurations without shadow passwords have been broken since the removal of telnet: as the default entry in /etc/passwd is not empty (but rather unset), there will be no way to log onto such a system by default. As disabling shadow passwords is not useful anyways, remove this configuration option. The config symbol is kept (for a while), as packages from feeds depend on it. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
-rw-r--r--config/Config-build.in3
-rw-r--r--package/network/services/dropbear/Makefile1
-rw-r--r--toolchain/uClibc/common.mk1
3 files changed, 0 insertions, 5 deletions
diff --git a/config/Config-build.in b/config/Config-build.in
index 6d81bef62d..7c82e8b3b7 100644
--- a/config/Config-build.in
+++ b/config/Config-build.in
@@ -47,10 +47,7 @@ menu "Global build settings"
config SHADOW_PASSWORDS
bool
- prompt "Enable shadow password support"
default y
- help
- Enable shadow password support.
config CLEAN_IPKG
bool
diff --git a/package/network/services/dropbear/Makefile b/package/network/services/dropbear/Makefile
index b80f4d5c81..41c66dd43c 100644
--- a/package/network/services/dropbear/Makefile
+++ b/package/network/services/dropbear/Makefile
@@ -66,7 +66,6 @@ CONFIGURE_ARGS += \
--disable-pam \
--enable-openpty \
--enable-syslog \
- $(if $(CONFIG_SHADOW_PASSWORDS),,--disable-shadow) \
--disable-lastlog \
--disable-utmpx \
$(if $(CONFIG_DROPBEAR_UTMP),,--disable-utmp) \
diff --git a/toolchain/uClibc/common.mk b/toolchain/uClibc/common.mk
index 878bd769f8..952f67d386 100644
--- a/toolchain/uClibc/common.mk
+++ b/toolchain/uClibc/common.mk
@@ -77,7 +77,6 @@ define Host/Configure
$(SED) 's,^KERNEL_HEADERS=.*,KERNEL_HEADERS=\"$(BUILD_DIR_TOOLCHAIN)/linux-dev/include\",g' \
-e 's,^.*UCLIBC_HAS_FPU.*,UCLIBC_HAS_FPU=$(if $(CONFIG_SOFT_FLOAT),n,y),g' \
-e 's,^.*UCLIBC_HAS_SOFT_FLOAT.*,UCLIBC_HAS_SOFT_FLOAT=$(if $(CONFIG_SOFT_FLOAT),y,n),g' \
- -e 's,^.*UCLIBC_HAS_SHADOW.*,UCLIBC_HAS_SHADOW=$(if $(CONFIG_SHADOW_PASSWORDS),y,n),g' \
-e 's,^.*UCLIBC_HAS_LOCALE.*,UCLIBC_HAS_LOCALE=$(if $(CONFIG_BUILD_NLS),y,n),g' \
-e 's,^.*UCLIBC_BUILD_ALL_LOCALE.*,UCLIBC_BUILD_ALL_LOCALE=$(if $(CONFIG_BUILD_NLS),y,n),g' \
-e 's,^.*UCLIBC_HAS_SSP[^_].*,UCLIBC_HAS_SSP=$(if $(or $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),$(CONFIG_PKG_CC_STACKPROTECTOR_STRONG)),y,n),g' \