summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCezary Jackiewicz <cezary.jackiewicz@gmail.com>2016-09-25 21:09:31 +0200
committerJohn Crispin <john@phrozen.org>2016-09-27 17:50:21 +0200
commit66aae9a27154f837607337fc099bd72fe4a9edf9 (patch)
tree3ac90d841f9bf7b5ae9c4cd742046286f2a9a3db
parent875cddd94cea002fae1b7eeb20ef2098410c44c1 (diff)
downloadmaster-31e0f0ae-66aae9a27154f837607337fc099bd72fe4a9edf9.tar.gz
master-31e0f0ae-66aae9a27154f837607337fc099bd72fe4a9edf9.tar.bz2
master-31e0f0ae-66aae9a27154f837607337fc099bd72fe4a9edf9.zip
ramips: Add support for ZBT-CPE102
- CPU: MT7620N 580MHz - Flash: 8MB - RAM: 64MB - build-in minipcie slot for modem 3G/4G - one ethernet port 10/100Mbps Signed-off-by: Cezary Jackiewicz <cezary@eko.one.pl>
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/ZBT-CPE102.dts118
-rw-r--r--target/linux/ramips/image/mt7620.mk7
7 files changed, 136 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 97c405d3fd..29bba0b26d 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -318,6 +318,9 @@ zbt-ape522ii)
ucidef_set_led_netdev "sys1" "wlan1" "$board:green:sys1" "wlan1" "tx rx"
ucidef_set_led_netdev "sys2" "wlan0" "$board:green:sys2" "wlan0" "tx rx"
;;
+zbt-cpe102)
+ ucidef_set_led_default "power" "power" "$board:green:4g-0" "0"
+ ;;
zbt-wa05)
ucidef_set_led_default "power" "power" "$board:blue:power" "1"
set_wifi_led "$board:blue:air"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 675dcc9832..e757acb6ab 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -53,6 +53,7 @@ ramips_setup_interfaces()
w150m|\
widora-neo|\
wnce2001|\
+ zbt-cpe102|\
zte-q7)
ucidef_add_switch "switch0"
ucidef_add_switch_attr "switch0" "enable" "false"
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 969594d8a6..1eb4036aab 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -208,6 +208,9 @@ get_status_led() {
wrtnode)
status_led="wrtnode:blue:indicator"
;;
+ zbt-cpe102)
+ status_led="$board:green:4g-0"
+ ;;
esac
}
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 98bc68c397..3a72835dbd 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -541,6 +541,9 @@ ramips_board_detect() {
*"ZBT-APE522II")
name="zbt-ape522ii"
;;
+ *"ZBT-CPE102")
+ name="zbt-cpe102"
+ ;;
*"ZBT-WA05")
name="zbt-wa05"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index e3a74e0928..a71d806a78 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -160,6 +160,7 @@ platform_check_image() {
y1|\
y1s|\
zbt-ape522ii|\
+ zbt-cpe102|\
zbt-wa05|\
zbt-we826|\
zbt-wg2626|\
diff --git a/target/linux/ramips/dts/ZBT-CPE102.dts b/target/linux/ramips/dts/ZBT-CPE102.dts
new file mode 100644
index 0000000000..b93e58526a
--- /dev/null
+++ b/target/linux/ramips/dts/ZBT-CPE102.dts
@@ -0,0 +1,118 @@
+/dts-v1/;
+
+#include "mt7620n.dtsi"
+
+/ {
+ compatible = "zbtlink,zbt-cpe102", "ralink,mt7620n-soc";
+ model = "Zbtlink ZBT-CPE102";
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ 4g-0 {
+ label = "zbt-cpe102:green:4g-0";
+ gpios = <&gpio1 14 1>;
+ };
+
+ 4g-1 {
+ label = "zbt-cpe102:green:4g-1";
+ gpios = <&gpio0 2 1>;
+ };
+
+ 4g-2 {
+ label = "zbt-cpe102:green:4g-2";
+ gpios = <&gpio1 15 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 1 1>;
+ linux,code = <0x198>;
+ };
+ };
+};
+
+&gpio1 {
+ status = "okay";
+};
+
+&gpio2 {
+ status = "okay";
+};
+
+&gpio3 {
+ status = "okay";
+};
+
+&spi0 {
+ status = "okay";
+
+ en25q64@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ linux,modalias = "m25p80";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x760000>;
+ };
+ };
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x4>;
+ mediatek,portmap = "wllll";
+};
+
+&wmac {
+ ralink,mtd-eeprom = <&factory 0>;
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ default {
+ ralink,group = "i2c", "spi refclk", "wled";
+ ralink,function = "gpio";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 003fc70210..28b5f3e160 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -358,6 +358,13 @@ define Device/zbt-ape522ii
endef
TARGET_DEVICES += zbt-ape522ii
+define Device/zbt-cpe102
+ DTS := ZBT-CPE102
+ DEVICE_TITLE := Zbtlink ZBT-CPE102
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += zbt-cpe102
+
define Device/zbt-wa05
DTS := ZBT-WA05
DEVICE_TITLE := Zbtlink ZBT-WA05