summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Blumenstingl <martin.blumenstingl@googlemail.com>2016-09-18 23:29:34 +0200
committerFelix Fietkau <nbd@nbd.name>2016-09-28 08:39:01 +0200
commit3fbd235fb5484236393341f168d927c7a6feb3f4 (patch)
treebdce49bb6348eb0171e0956c338a085646255df1
parent493b0f3f575520b35b6b01341b28147c67e90884 (diff)
downloadmaster-31e0f0ae-3fbd235fb5484236393341f168d927c7a6feb3f4.tar.gz
master-31e0f0ae-3fbd235fb5484236393341f168d927c7a6feb3f4.tar.bz2
master-31e0f0ae-3fbd235fb5484236393341f168d927c7a6feb3f4.zip
ath10k-firmware: update the qca988x firmware to 10.2.4.70.54
Use firmware version 10.2.4.70.54 from kvalo's git repository. The old version (even though it's version number is greater) is an old version from September 2015. Using only the firmware versions from kvalo's git repo is recommended, because those are tested by QCA's internal QCA. The QCA988X directory received a small reorganization as a "hw2.0" subdirectory was added - this patch also takes care of that as board.bin was moved to that subdirectory. Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
-rw-r--r--package/firmware/ath10k-firmware/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index 624da6a1ed..d3932401ce 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ath10k-firmware
-PKG_SOURCE_VERSION:=b00eb8d30fbebb6a5047ccacefa8c37e072fca9c
-PKG_VERSION:=2014-11-13-$(PKG_SOURCE_VERSION)
+PKG_SOURCE_VERSION:=307cb46b06661ebd3186723b5002de769c7add83
+PKG_VERSION:=2016-09-13-$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
@@ -66,18 +66,10 @@ $(Package/ath10k-firmware-default)
TITLE:=ath10k firmware for QCA988x devices
endef
-QCA988X_FIRMWARE_FILE:=firmware-5.bin_10.2.4.97-1
QCA988X_FIRMWARE_FILE_CT:=firmware-2-ct-full-community-16.1.bin-lede
QCA99X0_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-7.bin-lede.004
QCA9984_FIRMWARE_FILE_CT:=firmware-5-ct-full-community-7.bin-lede.004
-define Download/ath10k-firmware-qca988x
- URL:=https://www.codeaurora.org/cgit/quic/qsdk/oss/firmware/ath10k-firmware/plain/10.2.4/
- FILE:=$(QCA988X_FIRMWARE_FILE)
- MD5SUM:=fcb2fbd42d73a63fbf603505c718cbde
-endef
-$(eval $(call Download,ath10k-firmware-qca988x))
-
define Download/ath10k-firmware-qca988x-ct
URL:=https://www.candelatech.com/downloads/
FILE:=$(QCA988X_FIRMWARE_FILE_CT)
@@ -188,17 +180,17 @@ endef
define Package/ath10k-firmware-qca988x/install
$(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA988X/hw2.0
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/QCA988X/board.bin \
+ $(PKG_BUILD_DIR)/QCA988X/hw2.0/board.bin \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/
$(INSTALL_DATA) \
- $(DL_DIR)/$(QCA988X_FIRMWARE_FILE) \
+ $(PKG_BUILD_DIR)/QCA988X/hw2.0/10.2.4.70/firmware-5.bin_10.2.4.70.54 \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
endef
define Package/ath10k-firmware-qca988x-ct/install
$(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA988X/hw2.0
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/QCA988X/board.bin \
+ $(PKG_BUILD_DIR)/QCA988X/hw2.0/board.bin \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/
$(INSTALL_DATA) \
$(DL_DIR)/$(QCA988X_FIRMWARE_FILE_CT) \