summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-04-05 12:36:19 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-04-05 12:36:19 +0000
commit348cae15d2934f07a6c584261c2bee49cc43bbbd (patch)
tree5241e259d5acbebd270a980d9682235dff0d0211
parent46dfa04a083d6d08c31c9fd1f38bceb398f5dabe (diff)
downloadmaster-31e0f0ae-348cae15d2934f07a6c584261c2bee49cc43bbbd.tar.gz
master-31e0f0ae-348cae15d2934f07a6c584261c2bee49cc43bbbd.tar.bz2
master-31e0f0ae-348cae15d2934f07a6c584261c2bee49cc43bbbd.zip
buildroot: factor knowledge of a 64bits architecture
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 36204
-rw-r--r--rules.mk2
-rw-r--r--target/Config.in7
-rw-r--r--toolchain/gcc/final/Makefile2
3 files changed, 9 insertions, 2 deletions
diff --git a/rules.mk b/rules.mk
index 56129917e4..d9d38374fa 100644
--- a/rules.mk
+++ b/rules.mk
@@ -132,7 +132,7 @@ endif
LIBRPC=-lrpc
LIBRPC_DEPENDS=+librpc
-ifneq ($(findstring $(ARCH) , mips64 x86_64 ),)
+ifeq ($(CONFIG_ARCH_64BIT),y)
LIB_SUFFIX:=64
endif
diff --git a/target/Config.in b/target/Config.in
index 79a91b1afb..8ff89ff8a9 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -70,6 +70,9 @@ config HAS_MIPS16
depends (mips || mipsel || mips64 || mips64el)
bool
+config ARCH_64BIT
+ bool
+
# Architecture selection
config arm
@@ -104,9 +107,11 @@ config mipsel
config mips64
select BIG_ENDIAN
+ select ARCH_64BIT
bool
config mips64el
+ select ARCH_64BIT
bool
config powerpc
@@ -115,6 +120,7 @@ config powerpc
config powerpc64
select BIG_ENDIAN
+ select ARCH_64BIT
bool
config sh3
@@ -136,6 +142,7 @@ config sparc
bool
config x86_64
+ select ARCH_64BIT
bool
config ARCH
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index a667266a09..e8c32f629d 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -35,7 +35,7 @@ define CleanupToolchain
ln -sf ../include $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/sys-include
rm -rf $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib
ln -sf ../lib $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib
- $(if $(CONFIG_mips64)$(CONFIG_mips64el)$(CONFIG_x86_64),ln -sf ../lib64 $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib64)
+ $(if $(CONFIG_ARCH_64BIT),ln -sf ../lib64 $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)/lib64)
endef
define Host/Configure