summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-11 19:06:32 +0200
committerMathias Kresin <dev@kresin.me>2016-09-11 19:40:45 +0200
commit306f1c7846e3768dff51396c9dadce3956d5778f (patch)
tree00e7cc6676386963edec1f4aec141b419454f2de
parentec37a565878fd79d4127cbb843c17ce3b8dc97c0 (diff)
downloadmaster-31e0f0ae-306f1c7846e3768dff51396c9dadce3956d5778f.tar.gz
master-31e0f0ae-306f1c7846e3768dff51396c9dadce3956d5778f.tar.bz2
master-31e0f0ae-306f1c7846e3768dff51396c9dadce3956d5778f.zip
mvebu: fix OpenBlocks AX3 image
The KERNEL_SIZE variable is unset and no padding is applied. This looks like a typo to me since the ubinized image need to be aligned to the flash blocksize. Signed-off-by: Mathias Kresin <dev@kresin.me>
-rw-r--r--target/linux/mvebu/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index f3eda17a0b..7900fb9ddb 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -141,7 +141,7 @@ define Device/openblocks-ax3
DEVICE_DTS := armada-xp-openblocks-ax3-4
BLOCKSIZE := 128k
PAGESIZE := 1
- IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+ IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
DEVICE_TITLE := Plat'Home OpenBlocks AX3
endef
TARGET_DEVICES += openblocks-ax3