summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-24 06:13:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-24 06:13:14 +0000
commitfe525cd2c03aa7660b354b07bd095c556635994e (patch)
tree7b4bb2c87fc59f8ce9abf380b2e4058e4e8567a5
parent5da3667d79e14c17005fa4704531cf5cc7fe1fc2 (diff)
downloadmaster-31e0f0ae-fe525cd2c03aa7660b354b07bd095c556635994e.tar.gz
master-31e0f0ae-fe525cd2c03aa7660b354b07bd095c556635994e.tar.bz2
master-31e0f0ae-fe525cd2c03aa7660b354b07bd095c556635994e.zip
ar71xx: image: use the board name for temporary mtdpart files
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38149
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index c7e36af3d0..0b7c98fd3e 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -491,12 +491,12 @@ define Image/Build/UBNT2
$(eval fwsize=$(call mtdpartsize,firmware,$(3)))
$(call Sysupgrade/KRuImage,$(1),$(2),0,$$$$(($(fwsize)-4*64*1024)),64)
if [ -e "$(call sysupname,$(1),$(2))" ]; then \
- dd if=$(call sysupname,$(1),$(2)) of=$(KDIR_TMP)/$(1)-mtdpart-kernel.bin bs=1024k count=1; \
- dd if=$(call sysupname,$(1),$(2)) of=$(KDIR_TMP)/$(1)-mtdpart-rootfs.bin bs=1024k skip=1; \
+ dd if=$(call sysupname,$(1),$(2)) of=$(KDIR_TMP)/$(2)-mtdpart-kernel.bin bs=1024k count=1; \
+ dd if=$(call sysupname,$(1),$(2)) of=$(KDIR_TMP)/$(2)-mtdpart-rootfs.bin bs=1024k skip=1; \
$(STAGING_DIR_HOST)/bin/mkfwimage \
-B $(4) -v $(5).$(6).v6.0.0-OpenWrt-$(REVISION) \
- -k $(KDIR_TMP)/$(1)-mtdpart-kernel.bin \
- -r $(KDIR_TMP)/$(1)-mtdpart-rootfs.bin \
+ -k $(KDIR_TMP)/$(2)-mtdpart-kernel.bin \
+ -r $(KDIR_TMP)/$(2)-mtdpart-rootfs.bin \
-o $(call factoryname,$(1),$(2)); \
fi
endef