summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-23 15:28:36 +0000
committerJohn Crispin <john@openwrt.org>2015-05-23 15:28:36 +0000
commitfe35352d84f7129488d66c6c0775285ad656282a (patch)
treeb88a59853b419723db55b081a83b88604d6a9b59
parente2521a4bce13976cd6c702e53b7433a09ce4d8fb (diff)
downloadmaster-31e0f0ae-fe35352d84f7129488d66c6c0775285ad656282a.tar.gz
master-31e0f0ae-fe35352d84f7129488d66c6c0775285ad656282a.tar.bz2
master-31e0f0ae-fe35352d84f7129488d66c6c0775285ad656282a.zip
modules/sound: cleanup by removing unsupported Kernel cases
Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 45735
-rw-r--r--package/kernel/linux/modules/sound.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 54bc30ac32..3cf9834ebc 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -32,21 +32,11 @@ SOUNDCORE_FILES ?= \
$(LINUX_DIR)/sound/core/oss/snd-pcm-oss.ko \
$(LINUX_DIR)/sound/core/snd-compress.ko
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
SOUNDCORE_LOAD += \
$(if $(CONFIG_SND_DMAENGINE_PCM),snd-pcm-dmaengine)
SOUNDCORE_FILES += \
$(if $(CONFIG_SND_DMAENGINE_PCM),$(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko)
-endif
-
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.14.0)),1)
-SOUNDCORE_LOAD += \
- snd-page-alloc
-
-SOUNDCORE_FILES += \
- $(LINUX_DIR)/sound/core/snd-page-alloc.ko
-endif
define KernelPackage/sound-core
SUBMENU:=$(SOUND_MENU)