summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-08-10 14:15:06 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-08-10 14:15:06 +0000
commitfb9023bb8a7ac809435c6622506abcb3690d8d03 (patch)
tree50c5b89a160b7be7855a56542c681e15dc7004ed
parentc16bf519f18090d9563f50aa983247f80b8bd47d (diff)
downloadmaster-31e0f0ae-fb9023bb8a7ac809435c6622506abcb3690d8d03.tar.gz
master-31e0f0ae-fb9023bb8a7ac809435c6622506abcb3690d8d03.tar.bz2
master-31e0f0ae-fb9023bb8a7ac809435c6622506abcb3690d8d03.zip
move LIB_SUFFIX from base-files to rules.mk
Some packages are going to need fixups based on LIB_SUFFIX SVN-Revision: 33080
-rw-r--r--package/base-files/Makefile3
-rw-r--r--rules.mk4
2 files changed, 4 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index bb88d5d32d..441d394288 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -23,9 +23,6 @@ ifneq ($(DUMP),1)
ifneq ($(wildcard $(PLATFORM_DIR)/base-files-$(PROFILE) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)),)
TARGET:=$(TARGET)-$(PROFILE)
endif
- ifneq ($(findstring $(ARCH) , mips64 x86_64 ),)
- LIB_SUFFIX:=64
- endif
endif
define Package/base-files
diff --git a/rules.mk b/rules.mk
index 114b16ce3a..abb961e7de 100644
--- a/rules.mk
+++ b/rules.mk
@@ -122,6 +122,10 @@ endif
LIBRPC=-lrpc
LIBRPC_DEPENDS=+librpc
+ifneq ($(findstring $(ARCH) , mips64 x86_64 ),)
+ LIB_SUFFIX:=64
+endif
+
ifndef DUMP
ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
-include $(TOOLCHAIN_DIR)/info.mk