summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-26 16:57:27 +0000
committerJohn Crispin <john@openwrt.org>2014-10-26 16:57:27 +0000
commitf9a06347df9645f0587990135ebb7dd671371015 (patch)
treec89fed73511fcdbd5707aeefb1688c010eb857d7
parentd4754e1eb5ac024d7a8d649aa8b01c85a9e34649 (diff)
downloadmaster-31e0f0ae-f9a06347df9645f0587990135ebb7dd671371015.tar.gz
master-31e0f0ae-f9a06347df9645f0587990135ebb7dd671371015.tar.bz2
master-31e0f0ae-f9a06347df9645f0587990135ebb7dd671371015.zip
util-linux-dmesg: Add missing install section
Package util-linux-dmesg is broken (at least) in Barrier Breaker git repo as you can select it within menuconfig, it will compile (as a part of util-linux) but it will not install as install section is missing from package Makefile. Signed-off-by: Tomasz Wasiak <tjwasiak@gmail.com> SVN-Revision: 43069
-rw-r--r--package/utils/util-linux/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index 1490767878..7feafbf253 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -152,6 +152,7 @@ endef
define Package/dmesg
$(call Package/util-linux/Default)
TITLE:=print or control the kernel ring buffer
+ DEPENDS:= +librt
endef
define Package/dmesg/description
@@ -438,6 +439,11 @@ define Package/cfdisk/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/cfdisk $(1)/usr/sbin/
endef
+define Package/dmesg/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/dmesg $(1)/usr/sbin/
+endef
+
define Package/fdisk/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/fdisk $(1)/usr/sbin/