summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-24 22:03:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-24 22:03:34 +0000
commitf5b3f741cefd6e58ce9f9c90e327b5c8a2ce6c3b (patch)
tree7a773b11c67c6eb80002a1e85d79679c4eb000e7
parent61e492d3163e23e500f4d984980242b050f2bbcb (diff)
downloadmaster-31e0f0ae-f5b3f741cefd6e58ce9f9c90e327b5c8a2ce6c3b.tar.gz
master-31e0f0ae-f5b3f741cefd6e58ce9f9c90e327b5c8a2ce6c3b.tar.bz2
master-31e0f0ae-f5b3f741cefd6e58ce9f9c90e327b5c8a2ce6c3b.zip
uhttpd: allow lowercase http header fields (#8513)
SVN-Revision: 24823
-rw-r--r--package/uhttpd/Makefile2
-rw-r--r--package/uhttpd/src/uhttpd.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index b639c007b2..a0b7d24ebf 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=19
+PKG_RELEASE:=20
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_BUILD_DEPENDS := libcyassl liblua
diff --git a/package/uhttpd/src/uhttpd.c b/package/uhttpd/src/uhttpd.c
index 491452b634..2c7755f8da 100644
--- a/package/uhttpd/src/uhttpd.c
+++ b/package/uhttpd/src/uhttpd.c
@@ -339,8 +339,8 @@ static struct http_request * uh_http_header_parse(struct client *cl, char *buffe
hdrdata = &buffer[i+2];
}
- /* have no name and found [A-Z], start of name */
- else if( !hdrname && isalpha(buffer[i]) && isupper(buffer[i]) )
+ /* have no name and found [A-Za-z], start of name */
+ else if( !hdrname && isalpha(buffer[i]) )
{
hdrname = &buffer[i];
}