summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-05-26 21:58:24 +0000
committerNicolas Thill <nico@openwrt.org>2009-05-26 21:58:24 +0000
commitf4e312ddf855375667f43c842c7187934b8aca92 (patch)
tree5baa85ccedc9fb774853d62589a3035d6c1145a7
parent0fc0346e0a4364fb47700c28fbd7ffc56bb9048e (diff)
downloadmaster-31e0f0ae-f4e312ddf855375667f43c842c7187934b8aca92.tar.gz
master-31e0f0ae-f4e312ddf855375667f43c842c7187934b8aca92.tar.bz2
master-31e0f0ae-f4e312ddf855375667f43c842c7187934b8aca92.zip
iproute2: install netlink header and library
SVN-Revision: 16100
-rw-r--r--package/iproute2/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/iproute2/Makefile b/package/iproute2/Makefile
index 4fd34f20bb..a5d90f5a58 100644
--- a/package/iproute2/Makefile
+++ b/package/iproute2/Makefile
@@ -57,6 +57,13 @@ define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/include/libnetlink.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/lib/libnetlink.a $(1)/usr/lib/
+endef
+
define Package/ip/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_DIR) $(1)/etc/iproute2