summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-11-14 19:04:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-11-14 19:04:48 +0000
commitf38e6c782c917d7cfc5f19fad64a50423f759d6e (patch)
tree14b36945d78435bada0c05d81b5780ac121908f3
parentcc8350c5ec60e476983d923a4e34fd21a7e49829 (diff)
downloadmaster-31e0f0ae-f38e6c782c917d7cfc5f19fad64a50423f759d6e.tar.gz
master-31e0f0ae-f38e6c782c917d7cfc5f19fad64a50423f759d6e.tar.bz2
master-31e0f0ae-f38e6c782c917d7cfc5f19fad64a50423f759d6e.zip
ar71xx: use the new padjffs2 padding on Ubiquiti UAP-PRO to make the boot loader stop searching after the kernel partition
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 38805
-rw-r--r--target/linux/ar71xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3af8375a8c..d1e91c0aa1 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -448,7 +448,7 @@ define Image/Build/UAPPRO/buildkernel
-d $(KDIR_TMP)/$(2)/image \
2>&1 1>/dev/null | awk '/^.+$$$$/'
-rm -rf $(KDIR_TMP)/$(2)
- $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR_TMP)/$(2)-kernel.jffs2 64
+ $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR_TMP)/$(2)-kernel.jffs2 -J 64
endef
define Image/Build/UAPPRO