summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-27 23:46:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-27 23:46:34 +0000
commitf1a91c2f71dc557d8e7cf119dea99a1bb73e4f3d (patch)
tree5037c62c2061bf425e065a563cd2f6e958e42ba9
parent2c2bf90a8ed8b0ae12367888d9a43a7c192073cc (diff)
downloadmaster-31e0f0ae-f1a91c2f71dc557d8e7cf119dea99a1bb73e4f3d.tar.gz
master-31e0f0ae-f1a91c2f71dc557d8e7cf119dea99a1bb73e4f3d.tar.bz2
master-31e0f0ae-f1a91c2f71dc557d8e7cf119dea99a1bb73e4f3d.zip
move ccache to tools/ and fix potential dependency issue
SVN-Revision: 6413
-rw-r--r--toolchain/Makefile1
-rw-r--r--tools/Makefile3
-rw-r--r--tools/ccache/Makefile (renamed from toolchain/ccache/Makefile)0
3 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 4832a657df..7773c32c31 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -10,7 +10,6 @@ include $(TOPDIR)/rules.mk
TARGETS-y:=kernel-headers
TARGETS-$(CONFIG_GDB) += gdb
-TARGETS-$(CONFIG_CCACHE) += ccache
ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
TARGETS-y+=binutils gcc uClibc
endif
diff --git a/tools/Makefile b/tools/Makefile
index d03ab38ee3..8c5f699d32 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -8,6 +8,7 @@
#
include $(TOPDIR)/rules.mk
TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils
+TARGETS-$(CONFIG_CCACHE) += ccache
TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
@@ -28,7 +29,7 @@ ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
$(STAMP): $(TARGETS_INSTALL)
endif
-$(STAMP):
+$(STAMP): $(TOPDIR)/.config
mkdir -p $(shell dirname $@)
touch $@
diff --git a/toolchain/ccache/Makefile b/tools/ccache/Makefile
index e8e85b442a..e8e85b442a 100644
--- a/toolchain/ccache/Makefile
+++ b/tools/ccache/Makefile